Unable to Make Outgoing Calls

I installed FreePBX distro to a VM recently, and configured it to use VoIP.ms for the SIP trunk. However, I can only receive incoming calls. Can’t make outbound calls, no matter what I’ve change thus far. The original thread was posted here.

As stated in the original post, "When someone calls my DID number (incoming call), the IVR is successfully triggered. They then can dial an extension and be routed to the correct recipient. However, I can’t dial out. When attempting to make an outgoing call, I receive the following message:

‘All circuits are busy now. Please try your call again later.’ "

I collected CDR Reports, logs, and a screenshot here:

I think there’s something wrong with my Outbound route, but I don’t know what needs to be changed. I’m kinda new to this.

It’s matching your outbound route properly so I don’t think that’s the issue. This could be one of a few things, but I’m going to reach based on instinct:

Have you tried using an extension that doesn’t start with 0? I have had issues doing this in the past. Create extension 100 and try dialing out with that.

If that still doesn’t work, I would suspect something configuration specific to VoIP.ms but I don’t use them to know what it would be.

Have you tried calling any other phonenumber than the one in your picture?

It appears to have got a simple User Busy from voip.ms. However, always in these cases one really want to see the “pjsip set logger on” output fro both the INVITE and the final response, as that will confirm the exact SIP status code and reveal any additional information.

User Busy is not something one would expect the network to report, unless the called user really was busy.

I have not tried an extension not starting with 0 yet. I can try that in a bit.

Yes, sadly :slightly_frowning_face:

How would I go about configuring that? If it allows me to collect more info for troubleshooting, it’s worth ago.

replaced by the reply above

This was detailed in another posting today.

I’ve tried dialing:

  • 10-digit phone#
  • country code w/ 10-digit phone#
  • (+) country code w/ 10-digit phone#
  • (+) 10-digit phone#

All to no avail. I’ll try the Asterisk command you linked later today, and post the results.

Don’t guess, what you dial will be explicit in the individual trunk setup provided by your vendor, if you have more than one, each may have a different requirement, log files of failed calls generally show the failed ‘cause code’

In your log your provider is voip.ms and your failure is 17 (busy) but can you can confirm that by my request to check , all calls to other numbers all fail, and post the fail codes :wink:

419 [2022-09-17 20:41:31] VERBOSE[25865][C-00000001] app_dial.c: Called PJSIP/[email protected]
420 [2022-09-17 20:41:31] VERBOSE[25865][C-00000001] app_dial.c: Everyone is busy/congested at this time (1:1/0/0)
421 [2022-09-17 20:41:31] VERBOSE[25865][C-00000001] pbx.c: Executing [[email protected]:37] NoOp(PJSIP/0001-00000000, Dial failed for some reason with DIALSTATUS = BUSY and HANGUPCAUSE = 17) in new stack

https://wiki.voip.ms/article/FreePBX_/_PBX_in_a_Flash

pecifically shows that

NXXNXXXXXX

and

1NXXNXXXXXX

are supported over only licensed g729 , g711u and gsm

I tried calling a landline phone, a mobile/cellphone, and a Google Voice number that I own. All received the same failure prompt. For each number that I dialed, I tried all four different dialing variations. I didn’t collect logs for all dialing attempts, only the last few to my Google Voice number. I can re-attempt them all again and collect logs for each attempt if you want.

With pjsip logger on, please try calling 8004377950 also as 18004377950 and paste the log.

1 Like

Collect logs, without them we all can just guess.

1 Like

Sorry that I was unable to get back to you today. Work ended up being a lot busier than usual, so I had no time to attend to anything. Also ended up getting off late. Mentally fried for the day. I will get those call logs for you.

Scratch all that, not UK numbers just caught it the wrong way when looking at it. There is just an inconsistent outbound pattern happening here. You see some with outbound patterns as 1443NXXXXX, +1443NXXXXXX and +443NXXXXXX. Now the last one is going to present as International. Sounds like what others have said, need fully logger output.

Just also keep in mind that many cell carriers and other carriers have been started to prefix the CallerID Number with a + to help show what kind of number it is. When sending 10 digit CallerID with a 443NXXXXXX number many cell phones and other carriers could present that as +443NXXXXXX which makes it look like an incoming call from the UK. Just how 313NXXXXXX looks like a call from the Netherlands when a + is prefixed to it.

1 Like

I was attempting to dial the country code for the USA (1), along with the 10-digit phone number. If I dialed it wrong, then that may explain things. Please let me know how I should dial it, so that I may attempt a proper phone call.

See my edits I just made.