FreePBX | Register | Issues | Wiki | Portal | Support

Unable to make or receive two calls at the same time


(Alejandro) #1

Hi there I’m using a gateway GXW I have two lines connected I’m able to do and received calls the problem is if I’m using one line the other is not able two connect my question is how I can use two lines at the same time.
I have this in my Sip Destination Port: ch1-4:5060;
I assume that I need to use a different port for each extension how I can specify on my freepbx? if my freepbx is not on the same network I’m kind of confuse.
Thanks in advance.


(Kevin Frost) #2

Check out this guide:

https://wiki.freepbx.org/display/FPG/Call+Waiting+Module+User+Guide


(CCTS) #3

What kind of gateway? fxs or fxo? what’s the grandstream model #?

Is the GXW connected directly to the internet or are you behind a router? If router, what kind of router?

Perhaps you just need to create 2 extensions on your freepbx & put the extension number/name & passwords in the gxw.


#4

Are you referring to simultaneous incoming or outgoing? Simultaneous outgoing should work if you configure the round robin method correctly. Simultaneous inbound should work as long as your lines are configured as a hunt group by your provider, if what you mean by simultaneous is that you can receive two calls even though the dialed number is the same on both calls.


(Alejandro) #5

Model: GXW4104
FXO lines.
Simultaneous but different lines.
Example line 19518347**** is on call so another person calls to another phone number
95183456** it won’t connect because the port is been used in the other call.


#6

That is not the way it works. If one line is busy, the other line can still receive calls as it is connected on a different port.
Please post your trunk and gateway configuration.


(Alejandro) #7

This is one of them.
username=analogicphonenumber
type=friend
secret=clorets16
qualify=yes
host=dynamic
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw
insecure=port,invite

Second one:
type=friend
username=analogicphonenumber
secret=clorets15
qualify=yes
host=dynamic
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw
insecure=port,invite

I use different profiles on GXW to avoid confusion or any problem.
Thanks in advance…


#8

You don’t need two trunks and in fact the issue is because of that. Create only one trunk and configure the GXW for round robin port assignment. Or if you still want to use two trunks, you need to define the port assignment on GXW, first port is 5060, next 5062, next 5064 and so on, and define the trunks on FreePBX including the port parameter.
If you don’t know how to do it yourself, I can try to help you remotely.


(Alejandro) #9

This resolve the issue.
Port Scheduling Schema (VOIP->PSTN)
Round-Robin and/or Flexible: rr:1;rr:2;rr:3;rr:4;


#10

If you are only using port 1 and 2, that schema will not always work. You would use rr:1-2;rr:3;rr:4 and on the trunk on FreePBX you need to use port 5060.
Another example, if you are using only port 3 and 4, you would use rr:1;rr:2;rr:3-4 and you would use port 5064 on the trunk definition, assuming you didn’t modify the default port assignment on GXW, which is defined as 5060++

The way you defined it will only work if you define one trunk for each fxo port that you want to use and use the UDP port that corresponds to the fxo for each trunk, 5060 for fxo port 1, 5062 for fxo port 2 and so on.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.