Unable to locate teh FreePBX BMO Class Pm2 error while runing updating

I have been running the distro of FreePBX for 2 years and have regularly applied updates without any issues. Today I get the following error

I have searched on Google and came accross this which does not fix it The Module Named "pm2" is required

I have already installed the latest version of nodejs

image

exit: 1
Unable to continue. Unable to locate the FreePBX BMO Class 'Pm2’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install pm2 2) fwconsole ma enable pm2 in /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 213 #0 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(106): FreePBX\Self_Helper->loadObject(‘Pm2’) #1 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(37): FreePBX\Self_Helper->autoLoad(‘Pm2’) #2 /var/www/html/admin/modules/zulu/Zulu.class.php(39): FreePBX\Self_Helper->__get(‘Pm2’) #3 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(124): FreePBX\modules\Zulu->__construct(Object(FreePBX)) #4 /var/www/html/admin/libraries/BMO/Self_Helper.class.php(37): FreePBX\Self_Helper->autoLoad(‘Zulu’) #5 /var/www/html/admin/libraries/BMO/Hooks.class.php(298): FreePBX\Self_Helper->__get(‘Zulu’) #6 /var/www/html/admin/libraries/BMO/Hooks.class.php(39): FreePBX\Hooks->preloadBMOModules() #7 /var/lib/asterisk/bin/retrieve_conf(81): FreePBX\Hooks->updateBMOHooks() #8 {main}

As well when I check the logs I see this

Session terminated, killing shell…The process “runuser ‘asterisk’ -s ‘/bin/bash’ -c ‘cd /var/www/html/admin/modules/pm2/node && mkdir -p /home/asterisk/.pm2 && mkdir -p /var/www/html/admin/modules/pm2/node/logs && export HOME=/home/asterisk && export PM2_HOME=/home/asterisk/.pm2 && export ASTLOGDIR=/var/log/asterisk && export ASTVARLIBDIR=/var/lib/asterisk && export PATH=$HOME/.node/bin:$PATH && export NODE_PATH=$HOME/.node/lib/node_modules:$NODE_PATH && export MANPATH=$HOME/.node/share/man:$MANPATH && npm install --only=production’” exceeded the timeout of 600 seconds.

Problem solved. I rebooted the FreePBX server and then ran the following command and now it works again

fwconsole ma enable pm2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.