Unable to dial out internationally


(Honor's Haven It) #61

I get an error that says ‘the number is not answering’ Not sure if that means the number I’m dialing is just wrong or something…


#62

Have you confirmed that the phone is actually pulling this file?


(Honor's Haven It) #63

This is a issue than the one before. Before, it would just say silent, then go to a busy signal. Now it says ‘the number is not answering’ so I’d have to say it has to have pulled a new file. I don’t know where to confirm this data.


#64

If you have the usual tftp server, it logs to /var/log/messages


(Honor's Haven It) #65

Adding the
<TEMPLATE MATCH=“011*” Timeout=“5” User=“Phone”/> <!-- Int’l calling -->

Line has actually cause a complaint from staff; the system now takes longer to allow dialing out. I reverted the changes and it has cleared up the slow dialing issue.

Checking the logs before that don’t show me dialing out internationally when it was added onto the PBX. It only goes 6 digits in.

At this point, I don’t know what else to do


(Greg Kujawa) #66

I don’t understand how changing the dial plan for a single desk phone would affect the whole staff. If you just changed one phone’s config file. Optimally it’d be best to test on a single phone and see how it goes.

I’m not sure if the config file’s dial plan goes down in order of entries, but maybe placing that 011 line first in the order would be worth trying. If it takes an extra second or two to dial out, but you can get international calling to work then that’s certainly not the end of the world. I’d suggest Googling some international number you know will pickup. That way you know if it’s valid then it should answer!


(Honor's Haven It) #67

The dial plan I found was on the PBX server, I can’t remote into the phones on a signular basis. again, I don’t know what else to do at this point, I’m considering just shelving this whole thing as at this point in time, the deadline for getting this issue solved for the relevant phone call our team was going to make has passed. This phone system needs an overhaul, and that’s not something I have the know how to do.


(Greg Kujawa) #68

I guess if it’s a onesy-twosy request then you can probably move on. I run a multi-site retail company’s IT and we had one buyer who needed to contact an international vendor. One request in a year’s time. I finally configured international calling, but they were impatient and needed to make the call. Since they have a company-provided cell phone I just told them to use it for the one call.

Same with international faxing. We found that SIP calls were finicky going out from us in the USA to European recipients. I fiddled with T.38 and all sort of options, but it still was spotty. I weighed the cost of purchasing a dedicated copper POTS line just for one fax call a year, versus having the user scan and e-mail the document. Guess which option made more sense?

If it’s a constant need or even a regular one, that’s one thing. But if it’s a blue moon need then …


(Honor's Haven It) #69

I appreciate your help and everyone else in this thread that has assisted me on this. This request pops up rather uncommonly, maybe 1-5 times a year, but last year is a bit of an outlier, so we didn’t dial out all that much internationally at all. At this point, I would just suggest that we get a cell that can dial out with a phone card, as I’m beyond lost trying to patch the systems here that have been out of date for almost a decade.


(Greg Kujawa) #70

True. That phone model was the one that Jim used to prank Dwight on in The Office if I’m not mistaken.


#71

I suggest you rethink your whole dialing idea.

Why do you need to dial 8 before long distance, all long distance calls will be either 10 digits long or 11 digits starting with 1, All International numbers will start with 011 (except for some in the Caribbean and territories) or local numbers you can add a timeout to 7 digits. You will need to rearead how to prefix and prepend numbers in your outbound routes to match


(Honor's Haven It) #72

We dial 8 to dial outside our system, as the phones can contact any of the rooms in the facility. When dialing out, it’s followed by a ‘1’ so it usually looks like 81-845-XXX-XXXX. So by following that line of logic, I’ve been dialing as 8-011 before dialing out.
image

I’ve altered the prepend and prefix in several configurations, and I get stopped at the same thing each time; the first 6 digits are pushed through, but it refuses to go past that. That’s the issue I’ve been stuck with for the past week, ruling out everything else that was suggested.


(Greg Kujawa) #73

I can’t see the screen shots but do you have a trailing period at the end of the 011XXXXXX for the match pattern? I think it should be 011XXXXXX. (note the trailing period at the end.


#74

Do you have any rooms numbers starting with 011 ? , or do they all match [3-7]XXX


(Honor's Haven It) #75

I do on the second line there. The prefix is 8 and the match pattern as 011XXXXXX.


(Honor's Haven It) #76

No rooms start with 0.


#77

Then your dial string Then you don’t NEED to dial 8011X. but either way you would need a DialString that matches (8)011XXXXXX. (all international numbers are at least 7 digits after the 011)


(Honor's Haven It) #78

Welp, I just dialed out to that test number at the start without the 8 and it actually worked!


(Honor's Haven It) #79

Alright, I’m going to have our staff call out really fast just to make sure nothing has broken and I’ll be right back to close the thread if it does


#80

If, as you say, no rooms start with 0 , then they wont have dial real fast as 011 is getting you past it in less than 2 seconds, if you add a ‘.’ after your first dial rule