Unable to dial out internationally


(Honor's Haven It) #41

image

I managed to get past the ‘incorrect password’ error, but the system doesn’t dial at all which is odd


#42

pbx.lcal does not resolve from your PC. In MicroSIP Account settings, change Domain from pbx.lcal to 10.80.10.2

Also, make sure that Password in MicroSIP matches the value of Secret for the extension in elastix.

If the account is set up correctly, you should see a green Online indicator at the lower left of the main MicroSIP window.


(Greg Kujawa) #43

So were you ever able to access the phone’s configuration via the screen or a web client? If the web interface is enabled on this model, then the URL for accessing it would be https://{Phone_IP}/ccmuser. The default UID/PWD credentials (if not changed) should just be cisco/cisco.

Like some of the folks here mentioned, if the phone itself isn’t honoring the dial plan then the IP-PBX won’t even see the digits in their entirety. My uneducated guess is that the IP-PBX settings didn’t all of a sudden change. But the phones themselves might have lost their configs sometime. And therefore their local dial plan is missing key elements.


(Honor's Haven It) #44

image

This is where I am right now, These are the settings I have put into the soft phone. I’ve tried to access (over the network, and directly connected to the phone) via CCMUSER. I get an error (ERR_SLL_BAD_RECORD_MAC_ALERT). I feel like I’m jumping through hoops here, I just need international calling to work, this phone, and others like it didn’t have an issue dialing out previously, I think it’s a trunk issue. I will provide the trunk data if needed.


(Greg Kujawa) #45

This error typically means there’s a middleman that’s getting in the way. I’d recommend checking antivirus software to see if it’s configured to stop this page from loading. See https://support.google.com/chrome/thread/9268523?hl=en for some examples.


(Honor's Haven It) #46

image

What am I looking for here?


(Honor's Haven It) #47

image

Domain name is blank


(Greg Kujawa) #48

The domain wouldn’t need to be present if y’all are using IP addresses anyway. Peek into the configuration areas and see what the dial plan looks like. I haven’t worked with these types of phones in years, but I’m fairly sure there’s an online manual somewhere :grinning:


#49

Not a problem.

I see that it shows the IP of the PBX as TFTP Server 1. That’s good.
Are you certain that nothing appears in /var/log/messages when you reboot the phone? If so, possibly the TFTP daemon is not getting started. You can run tcpdump on the PBX to see whether the phone is making TFTP requests and what replies, if any, are being given.

Regarding MicroSIP, can you post current settings for the account and extension?


(Honor's Haven It) #50

image


#51

On the MicroSIP account, Login should be 3178 or left blank.


(Greg Kujawa) #52

I know this seems like a wild goose chase, but to simplify thing you can break the scenario down.

  1. International dialing previously worked.

  2. Now it doesn’t, so that points to a change somewhere.

  3. The change had to have occurred at least one place along the line. No pun intended. :yum:

  4. The three primary places to look at where a change could’ve happened would be a) the SIP service provider, b) the IP-PBX configuration, c) the phone configuration.

The closer you look at each of these places then I’m sure you will figure out the culprit!


(Honor's Haven It) #53

Services unavailable, that’s all I’m getting.


(Greg Kujawa) #54

I’m sorry I didn’t read all the way up the thread, but did you contact the SIP service provider first? To verify they allow international dialing? I know by default this wasn’t enabled for our own service. I had to enable it through their web portal. That’s the quickest and easiest thing to mark off the list.


(Honor's Haven It) #55

Our ISP doesn’t restrict international calling, I contacted them before starting this thread


(Greg Kujawa) #56

Well that narrows it down to two areas — the IP-PBX and the Cisco desk phones. If no one modified the IP-PBX config then odds are that the phones at some point in time had their configs somehow reset to default.

If the desk phones pull their configs via TFTP provisioning then that directory (assuming on the IP-PBX) should have the dial plans listed in it. Typically the filenames contain the MAC address matching each desk phone. See https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/manual/cmeadm/cmefiles.pdf for details.

That or if you can access the config via the web browser or via the phone’s display and key buttons you should see if 011 is included in there!


(Honor's Haven It) #57

image

I don’t see 011 listed there, do I just add it in?


(Greg Kujawa) #58

I honestly can’t see any of these screen shots. Sorry, but I’m older and don’t have a 35" monitor…lol.

Anyhoo, maybe put something like this in there (before the last template line) and save it?

<TEMPLATE MATCH="011*" Timeout="5" User="Phone"/> <!-- Int'l calling -->

(Honor's Haven It) #59

alright, that’s done, do I reset the phone or should I just dial out?


(Greg Kujawa) #60

The phone probably needs to be restarted in order to pull the config file down. If it’s doesn’t have a set autoprovision check or anything.