Unable to connect to the UCP Node Server. Error: xhr poll error

I am running freepbx 15. Users can log on to the UCP but now get this message. I have tried setting up a ssl certificate with the same results. Any advice apprecaited.

Seen this issue, i did not have an SSL, was using the Admin port (80) to get to the UCP, when i changed the URL to the UCP (which was 81) this error went away. SOunds basic, except, now i can use both 80 and 81 for the UCP and i dont see this error anymore.

I have since managed to get an SSL installed (however still using port 80)

so you changed it to port 81 and it worked? That doesn’t make any sense to me since that port is already open. Where did you change it?

http://domain.com/ucp (i saw the same error)
http://domain.com:81/ (did not see the error).

Between this being fixed, i put an SSL on AND the domain name worked (we did not use LE, manually saved the SSL and imported it

That said ive not seen the error since using either of the above URLs so really not sure what created it. We are using PBXact though so its not the freePBX, we can adjust the port management.

same error for me

The issue is because UCP cannot reach the necessary ports.

See UCP section: https://wiki.freepbx.org/display/PPS/Ports+used+on+your+PBX
(Port 8001 if you are using http)

I have all the ports open. I even turn the firewall off with same results

I have to ask the stupid quesetion…

Since it says “Unable to connect to UCP Node Server,” did you confirm that the UCP Node Server was running?

# fwconsole pm2 --list
+--------------+-------+--------+----------+-------------------+------+---------+
| Process Name | PID   | Status | Restarts | Uptime            | CPU  | Mem     |
+--------------+-------+--------+----------+-------------------+------+---------+
...
| ucp          | 23315 | online | 51       | 16 days, 17 hours | 0.1% | 87.28MB |
+--------------+-------+--------+----------+-------------------+------+---------+

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.