UCP locks up trying to display Call History

OK I have been watching the community forums, and running
occasional google scans for this, but it seems my problem is unique, so time to
report it and seek collective wisdom.

I have been operating FreePBX for around 2 years, with two deployments. One is my company office, with around 30 users,
the other is at my home with around 10 extensions. I use the home deployment as a test bed for updates
and changes.

Currently both deployments are on FreePBX 13.0.19 , “firmware”
6.12.65-31 and Asterisk 13. Both the
problems listed below happen on both deployments, which removes any network-specific
issues (as my home network is a very basic single segment).

I am trying to use UCP to display calls, and allow users to
access recordings.

Unfortunately we have two problems, one not so serious, and another
that makes it pretty useless. I am
reporting them both here, as they may be related (but I cannot see why).

1 – Loggin in with IE:

We have an internal url set up in dns “pbx.xx.xx.xx”, and if
we browse to that and click on UCP, or browse to “pbx.xx.xx.xx/ucp” or “pbx.xx.xx.xx:81”
with Internet Exploorer 11 (our company browser) the log-in screen hangs on “loading”,
without bringing up the fields for username and password.

If we log in with the real ip internal server address
10.0.x.x it works 100%.

If we use Firefox of Chrome, we can log in with the url no

We cannot see why this is happening – but are able to work around
by telling the users to go to the ip address.

2 – Call History display failing

This is the much more serious problem.

Any users, once set up to show call history (either on one
or several extensions), can click on “call History”, the headings appear, the
bottom row says “showing xx to xx of xx
rows” and the page numbers appear to the right.
For a seemingly random number of thee pages (around 10%, the display
works OK and dates, description, duration etc is shown. For all other pages, the display hangs, shows
“loading, please wait…” and the cog in the top right rotates forever. If the user selects another page, after
stepping through a few, one will work then the next few will not.

The ones that work sometimes include recordings, which play
OK, but anything on a page that will not display never appears.

If the “description” is deselected in the “columns”
selection, all pages display OK (but of course the only useful data is now

I am open to any suggestion on what to do next.

This is so corner case I can’t even replicate it. We use DNS all the time and it works.

These are javascript errors. Please provide some debug from the javascript console when this happens.

Thanks for the very prompt reply. This is from the Java console, let me know if you eed more:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://pbx.XXXXXXXXX:8001/socket.io/?token=4fd7bf1f86733a108d710894402d6e43&EIO=3&transport=polling&t=1447980838578-4. (Reason: CORS request failed).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://pbx.XXXXXXXXX:8001/socket.io/?token=4fd7bf1f86733a108d710894402d6e43&EIO=3&transport=polling&t=1447980844825-5. (Reason: CORS request failed).
TypeError: a is undefined jquery-1.11.3.min.js:2:2817
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://pbx.XXXXXXXXX:8001/socket.io/?token=4fd7bf1f86733a108d710894402d6e43&EIO=3&transport=polling&t=1447980850836-6. (Reason: CORS request failed).
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://pbx.XXXXXXXXX:8001/socket.io/?token=4fd7bf1f86733a108d710894402d6e43&EIO=3&transport=polling&t=1447980857099-7. (Reason: CORS request failed).

I should,. add, the “Cross-Origin request blocked” comes up several times whether the page works or not, the “TypeError” seems to be the critical one that comes up on pages that will not display.

I need you to expand “TypeError: a is undefined jquery-1.11.3.min.js:2:2817”

And re: my first problem (will not log in with IE) I now see in the httpd error log I get the following error every time:

[Fri Nov 20 14:08:13 2015] [error] [client] File does not exist: /var/www/html/ucp/assets/js/html5shiv.js, referer: http://pbx.XXXXXXXXX/ucp/

Is there a file I should have somewhere that is missing? Where can I get this file to put there, assuming that will fix the problem?

I am sorry, but am not totally sure how to provide what you need. I have clicked on the error in the console (in Firefox) and get a large quantity of text - is that what you need - how do I get it to you, it seems a bit too big for this medium.

If you do it in chrome it will make more sense and will be easy to take a screenshot of

You are using IE 8 or less. UCP won’t work very well in that version of IE. This is probably the cause of your other errors as well.

Is this what is needed?

This is from Chrome - seems quite a different error report though.


Next to the “uncaught TypeError” you need to click the “>”

Thanks. As for your IE issue. I suggest you stop using IE 8

I do really appreciate your help, but it is not an IE8 problem, we have not used IE8 for many years.

Note also the log-in problem only occurs on IE, the Call Record problems occur on all browsers…

Here is the IE version:

Here is the simple reason why I say you are using IE8 somewhere

	<!--[if lt IE 9]>
		<script src="assets/js/html5shiv.js"></script>

Notice the statement. “lt IE 9” This means less than IE9.

This will also report an error in the same way as we have walked through with Chrome (except it will be in Internet Explorer). If you can provide that it would be most helpful.

Interesting… thanks I have now solved it…

The browser has a default setting under compatibility mode:
“Display Intranet sites in compatibility view” and that was obviously triggering that script.

Now un-ticked, and the log-in problem is solved, we will roll out the change to all users (unless we find our Intranet still needs compatibility)

Many thanks

I have published CDR Reports and UCP right now with all of the fixes we have previously discussed in this ticket. :slight_smile:

cdr v13.0.19
ucp v13.0.14

Thanks - I take it that means you have published on git - but it will be a while before there is a module update that I can load?

They are in the online repository. You should be able to download them