UCP - Can not update Device Management


(Roel Sarceno) #1

PBX Firmware: 10.13.66-22
FreePBX 13.0.197.8
Asterisk version: 13.14.0
UCP Node Server13.0.34.9
User Control Panel13.0.42.7

I restart the application “fwconsole restart” and everything looks normal
Process is running
[root@pbx2 ~]# fwconsole pm2 --list
±-------------±------±-------±---------±----------------------±----±---------+
| Process Name | PID | Status | Restarts | Uptime | CPU | Mem |
±-------------±------±-------±---------±----------------------±----±---------+
| restapps | 32430 | online | 0 | 5 minutes, 10 seconds | 0% | 45.16MB |
| ucpnode | 333 | online | 0 | 5 minutes, 1 second | 0% | 65.46MB |
| xmpp | 403 | online | 0 | 4 minutes, 53 seconds | 0% | 208.79MB |
±-------------±------±-------±---------±----------------------±----±---------+

I can login to UCP, and make any modification except for Device management. The Device is a Sangoma S500. The error is “You are currently working in offline mode”. I check the forum and can’t find a solution.

httpd log is emply

The ucp_err.log show
There was an error with MySQL Connection
{ [Error: MySQL server has gone away] code: 2006 }

/var/www/html/admin/modules/ucpnode/node/lib/freepbx.js:94
throw “There was an error with MySQL Connection”;
^
There was an error with MySQL Connection
Error: ENOENT, stat ‘/var/www/html/admin/modules/ucpnode/node/lib/public/index.html’
at Error (native)

UCP_outlog looks good
Server up and running at 8001 port
{ AMPDBUSER: ‘freepbxuser’,
AMPDBPASS: ‘xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx’,
AMPDBHOST: ‘localhost’,
AMPDBNAME: ‘asterisk’,
AMPDBENGINE: ‘mysql’,
datasource: ‘’ }
Starting FreePBX…FreePBX is Ready!
Asterisk version is: 13.14.0
Loading all UCP Modules…
Loading…conferencespro.js
Loading…xmpp.js
Done!
Server up and running at 8001 port

Appreciate an info


(Itzik) #2

Which version of Endpoint Manager?


(Roel Sarceno) #3

Endpoint Manager 13.0.118.129 (not licensed but I’m using Sangoma Phones)


(Dave Burgess) #4

That’s “licensed for Sangoma Phones”. If you aren’t using it registered and licensed (even though it’s free), you’re going to get jammed up later.


(Roel Sarceno) #5

If you aren’t using it registered and licensed (even though it’s free), you’re going to get jammed up later.

What do you mean by jammed up? Is this a common issue?

I have two other servers with identical setup running (licensed thru Sangoma phone) for over 3 - 5 yrs. So far Device Mgmt is working on the UCP. All the servers has identical enable modules and revisions.


(Dave Burgess) #6

We’ve seen issues in the past where people bought the module, and got Sangoma phones and didn’t renew the license because they only had Sangoma phones, and the system goes all sideways. It takes Sangoma Tech Support to fix it.

If you’re all good, you’re all good.


(Roel Sarceno) #7

My other servers are good but still having problem with one server.

Blockquote It takes Sangoma Tech Support to fix it.

Is it too complex to fix it? Is the procedure written anywhere?

I read that Sangoma was using a third party plug-in (I think this is the node.js) which is causing the problem


(Itzik) #8

Update it, you are not on the latest version.


(Roel Sarceno) #9

Endpoint Manager 13.0.118.129 is the latest version.


(Itzik) #10

No it’s not. 13.0.127 is.


(Roel Sarceno) #11

I have a licensed for System Admin and I believe Module Admin if part of it
Under module admin, end point is showing 13.0.118.129 as the latest

How do I upgrade to 13.0.127?


(Lorne Gaetz) #12

Upgrade to edge using

fwconsole ma upgrade endpoint --edge

if problem persists, open a support ticket.


(Roel Sarceno) #13

I run “fwconsole ma upgrade endpoint --edge” but it downgrade instead of upgraded

[root@pbx2 ~]# fwconsole ma list | grep endpoint
| endpoint | 13.0.118.129 | Enabled | Commercial |

[root@pbx2 ~]# fwconsole ma upgrade endpoint --edge
Edge repository temporarily enabled
No repos specified, using: [standard,extended,commercial] from last GUI settings

Starting endpoint download…
Processing endpoint
Verifying local module download…Verified
Extracting…Done
Module endpoint successfully downloaded
Checking database tables…Done
Migrating tables as required…Done
Checking Settings and Defaults…Done
Generating Configs…Done
Downloading Firmware…Done (Background)
Generating CSS…Done
Module endpoint successfully installed
Updating Hooks…Done
Updating Hooks…Done

[root@pbx2 ~]# fwconsole ma list | grep endpoint
| endpoint | 13.0.109 | Enabled | Commercial |


(Itzik) #14

You have to renew EPM maintenance fee


(Roel Sarceno) #15

Just to confirm, they advertise Sangoma phone include the license for End Point Manager and other commercial module but you have to pay for End Point Manage maintenance fee. It doesn’t seem free!

If I pay for EPM maintenance fee, then does that mean the EPM will also work with other phones make and model like Yealink, etc. Correct me if I’m wrong, but if this is the case, then all phone (regardless of make and model) can advertise free EPM license (like Sangoma) as long as you pay for EPM maintenance fee.

I just purchased 11 Sangoma S505 so I can use EPM and Phone Apps because it include free license but in reality it is not included. What am I missing?


(Itzik) #16

Endpoint Manager and Phone Apps are free for Sangoma phones.
If you want to use EPM or Phone Apps for any other brand, you gotta purchase the full version of that module, once you purchased the module you gotta renew the annual maintenance fee to continue getting updates and support.

So, yes, EPM and Phone Apps are free for Sangoma Phones, no purchase required!

However, if you purchased the full version to use with other brands, you’ll have to pay the annual maintenance fee. No matter if you are also using that module with Sangoma Phones.

If you have purchased the full version of EPM in the past, but you are now using Sangoma Phones only, please contact support to remove the license so you’ll continue getting free updates.


(Roel Sarceno) #17

I’m hosted with CyberLynk (Freepbx Hosting Partner).
This includes EndPoint Manager and SysAdmin.
I’m guessing the Endpoint expired after a year
and when I run fwconsole ma upgrade endpoint --edge it downgrade it

I only need EPM and Phone Apps for Sangoma
I wish I knew this so before EPM was activated
The website show $149 for 25 year license or $75 for 1 year license
I don’t see any maintenance fee on the website for the product description

Anyway since I only need it for Sangoma which is free,
What do I need to make it work with Sangoma only.
Can you provide me the info and is this something I can do.

If not do I have to pay $395 to get two hr support to remove the commercial EPM but still get update for Sangoma? or is it cheaper to buy the maintenance fee. For being free this is costing me a lot of $$$.

Just to clarify, I only need EPM for Sangoma phones and I need my users to be able to login to UCP and change settngs on the Device Management.

Thank for the info


(Itzik) #18

Doesn’t say on the EPM page, but all commercial modules are like that.

Here’s how you can renew:

https://wiki.freepbx.org/display/FPAS/How+to+Renew+FreePBX+Commercial+Modules+Maintenance

Or you can go to the module admin module on your PBX, click check online and scroll down to EPM and click renew.

Customer service tickets are free.

How so?

Why don’t you contact them? If they purchased it for you, why not take to them?


(Roel Sarceno) #19

I just went ahead and renew it. it only $26.82 for deployment id 70328542.

Then I activate it.
Endpoint Manager Expiration Date 2041-07-08 (Free Updates until 2020-11-05)
Sys Admin Expiration Date 2041-07-08
Is there a maintenance fee for SysAdmin?

What’s my next step, do I go to System module and upgrade End Point Manager? Currently it show
EndPoint Manager 13.0.109

Should I run fwconsole ma upgrade endpoint --edge


(Lorne Gaetz) #20

If you have a paid version of EPM but you don’t need it, you can open a support ticket of type “Customer Service and Billing” indicating you wish to abandon your EPM license. You will then be able to use the free version indefinitely without fees.