UCP Buttons "Enabled/Disabled" never get translated? Weird partial translation ?!?

When changing the users language in UCP there is some weird behavior. Is this normal?

  1. When I add a widget, the widget gets name Username (EXT) and below this there is the name of what the widget does. This widget name is properly translated, but only on creation of the widget… So If I create the widget with UCP language to english and then switch to spanish or german, my widget name remains name “CALL FORWARDING” for example. I need to remove and re-add it for the language change to have an effect.

  2. Even weirder, even though almost the entire UCP seems to be translated (I only see some english in the tabs “OpenVPN” and “Xmpp”, deep in the configuration) - the buttons “Enabled” / “Disabled” as well as for example the prominent call forwarding conditions “Unconditional” “Unavailable” and “Busy” always stay in english.

I’ve tried this both with German and as well with Spanish because I read on some webpage that spanish is the most complete FreePBX Translation. But the buttons never get translated. Isn’t this a little weird? It there something broken with my installation? Does this work for other people here?

I have also tried:

  • clearing browser cache, loging out of UCP and back into UCP
  • setting global PBX language to de_DE instead of en_US
    but the button remain in English: Disabled/Enabled.


It looks like those strings aren’t translated. This may be a good spot to contribute.


Great idea, but they seem to be already translated in the german file, but the buttons still remain english:


Line 110-116:

#: ucp/views/widget.php:5 ucp/views/widget.php:10 ucp/views/widget.php:15
msgid “Disabled”
msgstr “Deaktiviert”

#: ucp/views/widget.php:5 ucp/views/widget.php:10 ucp/views/widget.php:15
msgid “Enabled”
msgstr “Aktiviert”

So I guess it must be something else? Content is the same locally in /var/www/html/admin/modules/callforward/i18n/de_DE/LC_MESSAGES/callforward.po

I don’t really really know spanish, I just tried spanish because I read this is the most complete translation available. I could contribute to the german translation, but it seems to be complete at least in this area?

Sorry quick reading on mobile I caught the spanish part so only looked at the spanish file.

Basically in the code if the string in the code is

_("Some String");

and has a corresponding entry in the i18 folder it should just work™

The only other thing I would look at is the cookie and make sure the lang cookie for /ucp is correct

Beyond that maybe open a ticket

Thank you James,

I’ve had a look at those i18n files but cannot determine why the translation is broken. Strings look fine as far as I can tell, but this is the first time I have ever looked at those gettext po / pot files. Those untranslated strings happen for me even with a fresh FreePBX 16 installation and with a different browser with all cookies deleted (the cookies were set to de_DE though). Can’t really submit a bug because I really don’t know where this is broken. And so far nobody has confirmed that I’m not the only one :frowning:

Update: OK, I don’t seem to be the only one, I’ve found this Bug: https://issues.freepbx.org/browse/FREEPBX-20334

How can I view the commits in the bug? I would love to see what caused the issue (just curiosity). issues.freepbx.org tells me I need to log in into two services, some git thing where my l/p for the FreePBX issue tracker was working find and Bitbucket @ code.sangoma.com, where my l/p from FreePBX/Sangoma Accounts don’t work. I also created an account at bitbucket.org but that isn’t accepted there either. I also don’t see a Sign Up button, just log in. How can I see those commits?

@lgaetz - I’ve also been running into this lately, can this be looked in to? Links to public JIRA within git are going to the internal JIRA system.

There’s three VCS (version control systems) at Sangoma. Public bitbucket (git.freepbx.org) on premise git server. Internal bitbucket (code.Sangoma.com) on premise git server and gerrit (asterisk git server) (https://gerrit.asterisk.org/)

The internal bitbucket server (code.Sangoma.com) is not accessible to anyone outside of Sangoma. But the atlassian ticketing system has an application link to internal and public. If a developer makes a commit with the ticket name in the commit message atlassian will link that commit or pull request to that ticket.

There’s really nothing to look into. Sometimes the developers work on code that is private but still relevant to a public ticket.

Note: I know this because I set it up this functionality when I worked at Sangoma years ago and the process is still the same today

By the way. The reason disabled and enabled aren’t translated is because the button is some jquery library and the library itself has settings to declare what the default strings would be for both enabled and disabled but that is not exposed as a translatable option. One would have to pull the i18n and put it as the default in the settings for the default button creator. Then in php one has to simply put down _(‘Disabled’) like James said so that the string extractor can pick it up to be translated. So it’s a two fold process 1) set the strings from i18n in the JavaScript library setup for the button 2) put those same strings in php so they can be picked up by the extractor

Yes, thanks.

The issue was actually something else. It seems that SSO between Bitbucket and JIRA isn’t automatically allowed anymore. I figured out how to fix this: When viewing code and clicking the issue hyperlink, if I click “Sangoma Issue Tracker” in the Authentication window, I am prompted to allow the integration and now it’s working. And vice versa, I needed to click Bitbucket when trying to view a PR from a JIRA issue.

It seems that each user needs to allow integration now?

You still won’t be able to view any code, commits or pull requests on code.Sangoma.com (but you can on the public one). Which is intended since that would have corporate intellectual property

Andrew, thank you for the explanation why the buttons were not getting translated.
Is there an way for me to see the code changes that fixed bug FREEPBX-20334 ?

According to the changes at issues.freepbx.org: Automated transition triggered when [Kapil Gupta] merged pull request #116 in FreePBX GIT - 25/Jun/21 7:36 AM

=> this fixed the bug (or at least marked it as resolved). But where can I see what pull request #116 in FreePBX GIT is? I can’t find it at: https://git.freepbx.org/plugins/servlet/all-pull-requests/all
Isn’t the FreePBX Git the public side? So there should be a way to see what this pull request is?

I was getting the prompt even for public issues (FREEPBX, not FREEI), and public code (git.freepbx.org). It’s solved, sorry for the clutter.

If it’s what yois said you just need to login to the public git server. But if it’s really internal then all you can do is scan through the commits yourself manually to see what was done. You can go this on either git.freepbx.org or on the GitHub mirror

Ok, so I guess the fix is somewhere in one of the commits in those git.freepbx.org repositories and I just can’t find it because I have no clue in which of the many repositories this bug is in. (It’s not in the callforward repo, since as you’ve explained it was a much more generic bug). Thanks for the explanation!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.