FreePBX | Register | Issues | Wiki | Portal | Support

Trying to wrap my head around how EPM works


(D E) #1

At the moment I have got a Digium D50 which is half talking to EPM. If I go to extension mapping and amend the template then do ‘save, build and update phones’ the phone responds and reacts to the command from the FreePBX GUI and dutifully restarts.
But the changes I’ve attempted to make don’t take effect.
Is this because I haven’t got Option 66 setup?


(D E) #2

So I’ve been trying to follow this guide:

https://wiki.freepbx.org/display/PHON/Setup+Phone+with+DHCP+Option+66

First hiccup is in System Admin I don’t have a Provisioning Protocols
"Note: http username & password could found in System Admin; Provisioning Protocols"
Further Googling reveals this is now a Pro feature?
So I try to go to

http://192.168.2.14:83

and I get

# Not Found
The requested URL /admin/config.php was not found on this server.

So then I try http://192.168.2.14:84 because it looks like HTTP provisioning has moved from port 83 to port 84.

On that port I get

# Forbidden
You don't have permission to access /.noindex.html on this server.

which I guess could be because I was using a web browser not a Digium phone??

On the phone apps port I get

{"application_name":null,"application_display":null,"page_name":null,"type":"display","exitPath":null,"layout":[],"action":[],"error":[{"reason":400,"display":"Phone Apps module not licensed."}]}

which is potentially a bit worrying because I was hoping to use visual voicemail.

Any help much appreciated!!

Thanks


(D E) #3

Wondering if I’d be better off with DPMA ? Seem to keep hitting obstacle after obstacle with EPM ? But am I right that with DPMA I wouldn’t be able to have BLF for other extensions in the building? That’s kind of why I’m trying to use EPM.


(Dave Burgess) #4

I don’t speak for Digium or Sangoma, but I suspect that you are experiencing the growing pains of subsuming DPMA into EPM.

The provisioning protocols option in System Admin shouldn’t be required for you to proceed, but there need to be instructions somewhere on setting this option for users without having Sysadmin Pro.

While it’s not considered “optimal” by most people, setting the phone to use TFTP provisioning should work just as well as HTTP/HTTPS in the local network. IIRC, all of the provisioning files are written into the /tftpboot directory and are served from there.

Now, you should have Phone Apps installed and licensed; you should get that for free with Digium and Sangoma phones if my reading of the tech support emails that have been posted here is correct.

You might need to drop a support ticket (you shouldn’t need credits) onto the system and have one of the folks that work with Chris @dolesec work with.

You might just be banging into a “you were here first” problem that’s not accounted for in the system right now. I’m pretty sure that what you want to do should be a LOT easier than is happening for you.


(D E) #5

Thank you. Thank you. Thank you.

This has been the most horrendous experience so far and it’s a HUGE relief to hear someone say: “Hey, this might not be on you”.

I’ve just had a really nice phone chat with a former Digium employee who worked on DPMA and he said DPMA CAN do BLF to reflect the state of other extensions so I think I’m going to give up on the horrors of EPM and try DPMA.


(Dave Burgess) #6

That’s an option, but remember that DPMA is no longer being developed or maintained (once again, if I’m reading the posts correctly) and it’s all being pulled into EPM. If that’s completely true, you’re tying yourself to the current version of Asterisk and FreePBX. Go in with your eyes open. Also, give @dolesec a chance to troubleshoot this for you. There’s a lot of development going on in EPM, so your issues could be good information for them.

You’ll have to completely uninstall EPM to get DPMA to install.


(Lorne Gaetz) #7

Provisioning of D50 works fine, I have one on my desk in front of me. The quoted statement indicates a misconfiguration of some sort. My wild guess is that the provisioning string in the config file is invalid, so the very first provisioning download works, and all subsequent ones fail.


(D E) #8

Hi - I’ve just manually given the phone a URL to download the CFG file from and it’s doing that. The only problem, possibly, is that it’s “updating” the phone’s firmware from the PBX. This isn’t something I’d told it to do, and I have a feeling the PBX has just downgraded the phone from 2.8.2 to 2.2.1.7?

Anyway, oh joy of joys, giving the phone a manual URL to download a CFG file from HAS worked.

There are things about the config that haven’t worked, like it hasn’t pulled in the custom logo I’d given it, but I’m sure I can tweak that…

But @lgaetz I’d be curious to know more about my misconfiguration!!

EDIT: Further developments

  • I’m now locked out of the phone’s internal web server which I guess makes sense. But it does mean I now have no way to update the background image if I can’t get it to work with EPM.
  • Amending the line keys isn’t working for some reason. I’ve tried coming up with different line keys to the ones I had in my first template, and sending them to the phone, and when I check the cfg file it’s not “letting go” of the ones I initially configured.
  • If I try to access visual voicemail via a soft key, I get a message “voicemail is not authorised in the phone apps module for extension 20”. When I got to the phone apps module to check, there’s no setting there that would allow me to turn on/off voicemail for specific extensions. When I check extension 20 to see if voicemail is enabled or not, it is enabled.

Still, this is progress. @lgaetz and @dolesec - if you want a willing tester/debugger - I’m your man! Let’s crack this!


(D E) #9

Another update. Deleting the template and re-creating it seems to allow me amend the line keys, when I first tried it I got another non graceful error that FTP was not suitable for provisioning this phone, I went back into the template and re-selected HTTP and that put paid to that error.

however, I now can’t receive or make phone calls from the phone!!

Oh, and the custom background image still hasn’t uploaded.


(D E) #10

Wow. The phone sure did not like being switched over to a new template. So far, the device remains UNREACHABLE


(D E) #11

Now it’s stuck in a firmware update loop. Firmware update failed. I have two options, retry and restart. If I choose ‘retry’, guess what, it fails, if I choose restart, it fails after restart.
EDIT: NOW it’s happily doing the firmware update…


(D E) #12

Now the phone is alive again…but it’s behaving VERY oddly.

If I place a call from a softphone to ANOTHER extension, unrelated to the D50, the D50 rings as well, then the call answers on hands free, then I’m subject to lots of followup random calls.

In Extension Mapping, the D50 is shown as

[192.168.2.17](http://192.168.2.17/) 
20/20 192.168.2.17 D No No A 5160 UNREACHABLE

(D E) #13

Have taken advice from various people who’ve experimented with FreePBX, DPMA and EPM. 90% of them said they’d had all sorts of trouble with EPM and just to use DPMA.
I’ve removed EPM and reinstalled DPMA and so far things seem to be going much better.
For one, DPMA seems to be able to use the latest D50 firmware whereas EPM always forced me to downgrade the firmware on the phone.
I can’t actually test functionality now as I’m not on site (just logging into the box remotely) but look forward to giving it all another go tomorrow (it’s a new day!) and have confidence it will be an easier process. And one small additional plus, mDNS will be easier than entering a manual config URL.
Thanks


(D E) #14

Just spotted this:


(system) closed #15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.