Trunk for Deutsche Glasfaser?


(Alex Dietz82) #1

Hello,
does anyone have the settings for Deutsche Glasfaser VoIP for me?
I have already tried a few things, but always get only Error 404 back.

Thanks


(Jared Busch) #2

Post their instructions. Someone can likely help you.


(Alex Dietz82) #3

They only gave the instruction to contact the manufacturer of the phone. I only have the standard access data, which is intended for a FritzBox.
However, I would prefer to use Asterisk.


(Jared Busch) #4

Thread from a year ago with what is likely most of it. Person was having issues, and no idea if it was fully resolved. That seems unclear.
https://community.freepbx.org/t/freepbx-no-outbound-inbound-calls/63370/5

That said, then what are the FritzBox instructions? The are only so many ways to do things.


#5

Please post that (mask username, password, phone number, etc., but make it clear what each item is).

Do you get the 404 when attempting to register, or on an outbound call? If the latter, is incoming working properly?


(Alex Dietz82) #6

The 404 comes when Asterisk tries to connect to SIP Server

I make Screenshots and post it later


(Alex Dietz82) #7

SG-General


(Alex Dietz82) #8

DG-Settings


(Alex Dietz82) #9

DG-Settings%20erweitert%201


(Alex Dietz82) #10

DG-Settings%20erweitert%202


(Alex Dietz82) #11

DG%20Codecs


(Alex Dietz82) #12

pjsip Logger said

[2021-01-20 17:05:38] WARNING[1280]: res_pjsip_outbound_registration.c:1035 handle_registration_response: DG-SIP: '404' fatal response received from 'sip:dg.voip.dg-w.de:5060' on registration attempt to 'sip:Phone Number@dg.voip.dg-w.de:5060', retrying in '30' seconds

== Endpoint DG-SIP is now Reachable
– Contact DG-SIP/sip:SIP_Username@dg.voip.dg-w.de:5060 is now Reachable. RTT: 9.086 msec

pjsip registration said

DG-SIP/sip:dg.voip.dg-w.de:5060 DG-SIP Rejected Wed 17:07:38 30 Wed 17:08:08 22


#13

I’m very confused. You have Registration set to None, but you are still getting errors attempting to register. I would assume that receiving incoming calls from this provider would require registration. Please explain.

Also, please post the suggested settings for FritzBox.


(Alex Dietz82) #14

I tried also Send and Receive. But the request is stil rejected.

The settings in the Fritzbox was very easy. I just needed my Phonnenumber, Username and Password


#15

I looked at the FritzBox GUI and believe that what they call Username is what Asterisk calls authuser, which unfortunately is not supported by the FreePBX GUI.

Please try these settings, where you set Authorization user manually in a config file:

Edit /etc/asterisk/pjsip.auth_custom_post.conf to contain (in addition to anything already there)
[DG-SIP](+type=auth)
username=SIP_DG Username

Change these settings for trunk DG-SIP:
Username: phonenumber
Registration: Send
Contact User: leave blank
From User: phonenumber
Client URI: (leave blank)
Server URI: (leave blank)

For phonenumber, use what DG gave you for the FritzBox (either 02864… or 00492864…)

Restart Asterisk and test. If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make or receive a failing call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

If registration fails, paste a registration attempt instead of a call.


(Jared Busch) #16

Is it not available in advanced? I thought I dealt with this once in the past. I’m not at my desk to check at the moment.


#17

Possibly added very recently, maybe in edge. However, it isn’t present in what the OP is running so I figured that a manual config edit was in order.


(Alex Dietz82) #18

The /etc/asterisk/pjsip.auth_custom_post.conf is completely empty. Is this right?

I have something in the pjsip.auth.conf
[DG-SIP]
type=auth
auth_type=userpass
password=PW
username=Phonenumber

Should i change it in

[DG-SIP]
type=auth
auth_type=userpass
password=PW
username=SIP_DG Username

??
Sorry, I’m a complete beginner


(Alex Dietz82) #19

Ok, i tried it.

The log says
== Endpoint DG-SIP is now Reachable
– Contact DG-SIP/sip:PHONENUMBER@dg.voip.dg-w.de:5060 is now Reachable. RTT: 14.177 msec

But in the Registry is this
Registration/ServerURI…> <Auth…> <Status…>

DG-SIP/sip:dg.voip.dg-w.de:5060 DG-SIP Rejected Thu 00:15:02 30 Thu 00:15:32 8
Sipgate/sip:sipgate.de:5060 Sipgate Registered Thu 00:10:08 590 Thu 00:19:58 274

Objects found: 2

[2021-01-21 00:15:32] WARNING[1343]: res_pjsip_outbound_registration.c:1035 handle_registration_response: DG-SIP: ‘404’ fatal response received from ‘sip:dg.voip.dg-w.de:5060’ on registration attempt to ‘sip:Phonenumber@dg.voip.dg-w.de:5060’, retrying in ‘30’ seconds

Is it possible that i need USERNAME + PHONENUMBER @ dg.voip.dg-w.de:5060 ?
Because i have 3 Phonenumbers with one SIP Account


#20

If you have this account working with a FritzBox, softphone or other device, a log or capture from the device would be useful, so we can see how the register request is formatted and make Asterisk do the same thing.

If not, turn on pjsip logger (as noted earlier), paste a failed registration attempt and post the link. Then, change Username to SIP_DG Username (leaving everything else alone), turn on the logger again, paste a new failed attempt and post that link. We can compare and see whether one or the other attempts to authenticate.