Trunk for Deutsche Glasfaser?


#21

I found


which makes it pretty clear that Username should be the phone number, but a log with a registration attempt with the current settings may give a clue as to what is wrong.


(Alex Dietz82) #22

Ok, this is the log from the FritzBox.

https://pastebin.freepbx.org/view/1531fa06


#23

Looks good, except possibly for SIP ALG in the path.
Please provide similar log from Asterisk attempt.


(Alex Dietz82) #24

Ok, this is from Asterisk CLI via CMD

https://pastebin.freepbx.org/view/5a490113


(Jared Busch) #25

use sngrep we need to see the registration packet.


(Alex Dietz82) #26

Ok, but I need more information. Do I have to install it or just start it, and how?


#27

No SIP in there. At the Asterisk command prompt, type
pjsip set logger on
and paste the Asterisk log for a register request and the replies.


(Alex Dietz82) #28

Ok, this is the Line from pjsip logging

https://pastebin.freepbx.org/view/69cf9b22 (I changed it)

This is a big different " Authorization: Digest username=“DG-User”, realm=“dg.voip.dg-w.de”, nonce=“60096cb7e8fee1a273b023d7b432d3a1b19f79ff”, uri=“sip:dg.voip.dg-w.de”, response=“2cc6a76580905ad83941f1d1b4941a68"”


#29

What you pasted shows only the register and 401. This should be followed by an ACK, a REGISTER with an Authorization header, and the response (404?) to that. Please post a more complete attempt.

However, in Line 21, received=100.68.67.46 looks suspicious. Do you really have a shared (NATted) IP address from DG, or is this an artifact of their internal routing? Does your router have this address on its WAN interface, or does it have the 94.31.x.x address?


(Alex Dietz82) #30

Oh fuck, this 94.31.x.x is my WAN Adress :fearful:


(Alex Dietz82) #31

I Changed the PasteBin
https://pastebin.freepbx.org/view/69cf9b22


#32

OK, the problem is that the auth user isn’t propagating to the username in the Authorization header.

Please confirm that /etc/asterisk/pjsip.auth_custom_post.conf contains:
[DG-SIP](+type=auth)
username=DG-User

where DG-SIP is the trunk name in your GUI and DG-User is what you have for Username in FritzBox.

If you change this you must restart Asterisk.

If you still have trouble, paste a new SIP trace from Asterisk.


(Alex Dietz82) #33

The pjsip.auth_custom_post.conf is komplete empty.
Should i try pjsip.auth.conf instead? There i have the Username and Password vor Trunks


(Alex Dietz82) #34

No way. I´m soooo Happy.
I changes the pjsip.auth.conf

<Registration/ServerURI…> <Auth…> <Status…>

DG-VoIP/sip:dg.voip.dg-w.de DG-VoIP Registered Thu 18:41:19 60 Thu 18:42:19 31
Sipgate/sip:sipgate.de:5060 Sipgate Registered Thu 18:41:17 590 Thu 18:51:07 559

Objects found: 2

THANK YOU so so much


#35

That file will be overwritten if you make any changes in the GUI, so you should put the change in pjsip.auth_custom_post.conf instead, using the suggested format to indicate an override.

Also, getting registered is only half the battle – can you actually make and receive calls?


(Alex Dietz82) #36

Ok, shoul i copy and paste everything from pjsip.auth.con in pjsip.auth_custom_post.conf?

First I have to configure INBOUND and OUTBOUND correctly.


#37

My recommendation is putting only two lines into pjsip.auth_custom_post.conf , because that will allow you to change any other parameters from the GUI. However, I don’t see any problem with entering more options, if you have a reason to do so.


(Alex Dietz82) #38

Ok, Inbound does not work. As if busy and Asterisk does not seem to receive any call. Outbound does not work either. Announcement, all lines are busy


#39

For outbound, paste a SIP trace of the attempt.

For inbound, see whether the attempt shows in sngrep. If not, post details about your router/firewall.


(Alex Dietz82) #40

One failure, asterisk sends username=Phonenumber again although the custom post contains the lines
[DG-SIP]
username=DG-USER

Problem with sngrep, i don´t know how to install this to my Raspbarry4