Trunk between MP114 and freepbx

configuration
Tags: #<Tag:0x00007f702ce42db8>

(Suriname) #1

Hi,

i want to use MP 114 as fxo gateway for my freepbx. But in the command line i am getting this warning:
[2020-07-03 05:09:43] WARNING[1197]: res_pjsip_registrar.c:1073 find_registrar_aor: AOR ‘’ not found for endpoint ‘AudioCodesMp114’

And when i am using this command:
pjsip show endpoints

I can see that there is a trunk:
Endpoint: AudioCodesMp114 Not in use 0 of inf
Aor: AudioCodesMp114 0
Contact: AudioCodesMp114/sip:192.168.1.101:5060 59e267ce78 Avail 30.074
Transport: 0.0.0.0-udp udp 3 96 0.0.0.0:5060
Identify: AudioCodesMp114/AudioCodesMp114
Match: 192.168.1.101/32

I do not understand what the issue is


(Dickson) #2

Take a look at this, see if this document helps


(Suriname) #3

thank you for this information.i have verified,and I have configured the same way.Still I am getting this warning.Cna you maybe also tell me how I can register the FXO port,so maybe I cound test


#4

That error is because you created a chan_sip trunk but are pointing the mp114 to the pjsip port or vice versa.
What type of trunk have you created and what port are using chan_sip and pjsip?


(Suriname) #5

Hi on the freepbx i am using chan pjsip, port5060.
In the message log of the MP 114 I can see that the dns is not being resolved. Is that maybe the issue


(Suriname) #6

I am also unable register the fXO port, can someone help me please


(Suriname) #7

i have set the trunk, on the freepbx i can see that that trunk is online. It was because of the settings, the gateway name that the trunk could not be set up.

The only issue I have now is that FXO port is not registering. Can you guide me with that?


#8

If the gateway is in the same local network as the PBX, you can first try to connect without registration so you can make it work and then move forward.


(Suriname) #9

hi, yes they are on the same network. I have connected an analog line to the fxo port. But the port is not registering. Now i have the trunk between my freepbx and the MP114, i wanted to test a call. But I have no succes.
what can I do further?


#10

Disable registration both on the MP and on the FreePBX trunk.


(Suriname) #11

I am talking about this

This is my configuration on the MP114







(Suriname) #12

Here is one more screenshot


(Suriname) #13

The port i have connected the analog line is port 4. The ip address of my MP114 is 192.168.1.101 and the ip address of my freepbx is 192.168.1.100


#14

I understand what you are saying, and that is why I told you to first try to setup the trunk without registration. Especially if you are using PJSIP, since you will find it difficult, if not impossible, to make it work, because PJSIP doesn’t “understand” correctly when registration for both and endpoint and a trunk is coming from the same IP.


(Suriname) #15

Okay i will to that as you say


(Dickson) #16

2 suggestions.

  1. ONLY USE INTERNET EXPLORER when configuring an AudioCodes. OMG have I ever seen weirdness right up to at least firmware release 6.60A.326.005. Chrome and FF have both F’d me on these in the past, and I’ve done a bunch.

  2. Try and “ENABLE REGISTRATION” on your Proxy & Registration page.

…also I dont recall ever seeing brackets <> around the IPs in a AudioCodes config before.


(Suriname) #17

okay i am going to use internet exploreer, and i must have forgotten to remove the brackets. thank you


(Suriname) #18

I have triend to setup the trunk. In the freepbx, I can see that the trunk is online. Still I cannot get the port registered. Tell me If iam doing something wrong. I have connected aan analog line to the FXO port. I have a trunk between the Freepbx and Voip gateway. i want to make outbound and inbound calls using thhrough this trunk, using the analog line.


#19

Just don’t use registration. And disregard the message that says NOT REGISTERED, because you are not using registration.


(Suriname) #20

I do not thin I understand what you mean. Now is the situation that I have a trunk. How will I then make outgoing calls through the analog line if the port is not registered? Now I am also not able to perform outgoing calls or get incoming calls. How can i make this possible