Transferred calls dropping

Hi all,

We have an issues with transferred calls. All of the external calls are dropping after a few seconds when transferred to internal extensions. Any idea where should I start to troubleshoot this please?


Provide an Asterisk log of a failing call.

Background information would also be useful (system version, platform, firewall, phone type, using transfer key or DTMF, do both blind and attended transfers fail, does it matter whether the external call is incoming or outgoing, etc.)

Hi Steward,

I will try to generate the logs and put it here. I have another weird issue now after Upgrading the Dashboard module yesterday, the GUI is not loading. I had to reboot the system this morning to get it to work. Not sure how to get the call ID if the GUI is not working. :frowning:

The Asterisk log is stored at
You can also run
asterisk -vvvvvr
at a root shell prompt and logging info will appear on the console.

At the Asterisk console prompt, type
sip set debug on
for a chan_sip trunk or
pjsip set logger on
for a pjsip trunk, before making your test call, which will show SIP packets interspersed in the log.

Paste the log at and post a link here.

Hi Stewart,

Sorry for the delay on this, I tried pasting the full log to the pastebin link but it’t just not working. :frowning:

I’m almost wondering if its an issue with the actual device (the extension you are trying to transfer to) sending a cancel request considering it only happens when you transfer to internal extensions. What type of phones are you using and can you post a packet capture. One quicker way to rule that out if possible is to download XLite softphone and transfer a call to that.

Hi Robert,

It’s happening on multiple handsets, we are using Cisco 7940 phones. We have done some more testing and it seems like the calls only drops if there is another call in progress. Not sure how this is related but this is our finding so far on this. If there is only one call the transferred call doesn’t drop. I have finally fixed access to the GUI… pheeww… will try to get the logs and post here.


With the Cisco phones are you using the SCCP channel driver with FreePBX or do they have SIP firmware?

They are on SIP firmware, i have managed to get log for one of the dropped call. Hopefully this can shed some lights.

@Stewart1 @rfreeman1478

Thanks guys.

Will try to pull some more logs for other dropped calls.

Think I found it. Line 207 on the pastebin. It shows your endpoints arent allow the update method

Add this in the sip.conf file and then

run fwconsole restart to reload everything

disallowed_methods = UPDATE

Tried that and it’s still the same. I put the line in the UA section in the config as I am using Endpoint Manager.

I think I didn’t add the line correctly, the phones are now showing W320 1 Error Parsing: SIPmac.cnf

add it under the general context [general] or you can go into the gui under Settings > Asterisk SIP Settings > Chan SIP Settings > Other SIP Settings

I have added this to the settings, will test and get back to you. Hopefully this one works. Thanks for your help!

Hi, I think we have nailed this down… so far so good with this transfer. Would you know what could have changes? It was working all good and then it just stopped. I have another small issue now after making the change. I setup our CMR to dial via the pbx. After making this change, the CRM will dial my phone but when I pick up it’s just blank, it seems like it doesn’t dial the number from the CRM which is how it was working before. btw the CRM is Connectwise. Thanks again for your help.

Logs. We can’t troubleshoot anything without logs.

Is your VOIP service provider using a SIP trunk or PJSIP trunk? Asking because based on the type of trunk you have, it will change the location of where I want you to make the next change.

Hi, it used to be pjsip but they had us change it to sip a couple of months ago. Thanks.

Ok cool. remove the disallowed_methods = UPDATE from the sip.conf (or Other SIP Settings in the gui) and add it in the peer details of your sip trunk with no spaces.