So I have been trying to implement TLS and SRTP on my FreePBX 6.12.65-27. I am using Cisco SPA525G2 endpoints and have followed the guides from multiple sites to try to get it working. I used:

I have gone through the steps from the guides and I am getting the error below when I try to apply the config:

Please update your modules and reload Asterisk by browsing to your server.
PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Permissions error on file /etc/asterisk/keys/asterisk.pem - please re-run as root to automatically repair’ in /var/www/html/admin/libraries/BMO/PKCS.class.php:643
Stack trace:
#0 /var/www/html/admin/libraries/BMO/PKCS.class.php(52): PKCS->checkPermissions()
#1 [internal function]: PKCS->__destruct()
#2 {main}
thrown in /var/www/html/admin/libraries/BMO/PKCS.class.php on line 643

I am not a Linux guy so I am not sure what to do to get this issue resolved. I haven’t even started on the SRTP part, because the TLS is what is giving me the error. Any help with this would be greatly appreciated. Or, if anyone knows of an updated guide on settings this up that I have failed to locate using Google, that would also be appreciated.


I got the error to go away by deleting the directory as I was not using that directory anyway. I am still not able to get TLS working though, the endpoints will not register when forced to TLS. Does that common name on the certificate that was generated need to be the LAN address of the FreePBX or the LAN hostname? I generated it using the hostname so I am about to try re-generating it using the LAN IP as the common name to see if that names a difference.


I seem to have figured this out finally. Now my only issue is that the Cisco SPA525 phones have a double beep during active calls every few seconds. I assume that it is letting me know that the call is secure but I can’t seem to find a way to disable the alert. It is a low beep followed by a higher pitched beep (boobeep). Any ideas?