Time groups not working


(Mikelovell) #1

i have fully setup time groups and time conditions in freepbx 15 but they refuse to work. i still get calls in the out of hours time frames. any ideas? server time is correct.


#2

Logs are always helpful


(Mikelovell) #3

how do i send the log here thanks ?


#4

Well, first you read and try and understand them, if you have a question pastebin is the generally recommend method (there is a FreePBX pastebin I believe)


(Mikelovell) #5

of course i have read them, but im not quite at that technical level for that.
the logs seem quite large, is it appropriate to paste that all here?


(Lorne Gaetz) #6

No. Isolate a specific problem call and share via pastebin:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


#7

There is always ‘paid support’ if you want to skip that step :wink:


(Mikelovell) #8

[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] pbx.c: Executing [s@macro-dial:6] AGI(“SIP/SIP095761333-00002a31”, “agi://127.0.0.1/dialparties.agi”) in new stack
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Starting New Dialparties.agi
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Caller ID name is ‘64275827557’ number is ‘0275827557’
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: CW Ignore is:
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: CF Ignore is:
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: CW IN_USE/BUSY is: 1
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Methodology of ring is ‘ringall’
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Added extension 202 to extension map
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Added extension 203 to extension map
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Added extension 207 to extension map
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Extension 202 cf is disabled
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Extension 203 cf is disabled
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Extension 207 cf is disabled
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Extension 202 do not disturb is disabled
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Extension 203 do not disturb is disabled
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Extension 207 do not disturb is disabled
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: dbset CALLTRACE/202 to 0275827557
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: dbset CALLTRACE/203 to 0275827557
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: dbset CALLTRACE/207 to 0275827557
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: Filtered ARG3: 202-203-207
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: RVOL_MODE ‘’
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: RVOL is:
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: agi://127.0.0.1/dialparties.agi: RVOLPARENT is:
[2020-07-14 11:39:41] VERBOSE[17288][C-000024d3] res_agi.c: <SIP/SIP095761333-00002a31>AGI Script agi://127.0.0.1/dialparties.agi completed, returning 0


#9

Nope, nothing about time conditions here try grepping out C-000024d3 from your log file, then send it to a pastebin of your choice


(Mikelovell) #10

sorry. wrong topic. my call logs dont seem to go back to this early morning. but i have working hours set up at 9am to 5pm, yet im still getting incoming calls at 8:50am when they should be getting an out of hours recording instead. the phones still ring in the out of hours times which they shouldnt, it should divert directly to out of hours.


#11

Then post the logs of a failed called as suggested


(Mikelovell) #12

yes, but as i said, my logs are only going back to around 11:44am and the call cam in at 8:50am how do i find a log from that early ?


#13

You likely have a rotating log system (logrotate, defined in /etc/logrotate*)

ls -lasrt /var/log/asterisk/*

would reveal how effective your log-rotation is and looking at the date (which reflects when it was closed) , derive which file to investigate


(Mikelovell) #14

ok. my skill livel is limited to the GUI only, i dont do command line. can i get what is needed from the webpage where i manage the system ?


#15

Maybe, use the same bashism’s, they might work, but even gooey limited folks have managed to get their heads around putty. (a command line tty interface wrapped around a windoze gooey thing)


(Mikelovell) #16

i can use putty, i just dont like to break things that are working. and when i go in there. i tend to break things.


#17

Kind of a Catch22 there Yossarian. Either grow some or pay someone else maybe :wink:


(Mikelovell) #18

entirely happy to pay someone to get the solution.


#19

at the top of this page there is a link for “support”


(Mikelovell) #20

from Sangoma ?