Time flashing or blinking on Polycom IP 331 phones

asterisk
Tags: #<Tag:0x00007fafcdeaf5b8>

(6 Taylor) #1

Hello. We are having this issues with time blinking on our Polycom IP 331 phones. We had an Asterisk server that broke down, so we have to build another one from scratch. Several configurations weere taken from previous server that worked properly. We managed for the clock from server and harware clock are syncronized, and it is important to mention that we live in Venezuela, South America, so we need for our server to get the correct hour and display it on the Polycom phones.

That is what we have done so far:

1-This what I have on “nano /etc/ntp.conf”, there are some server that we have after “#”

For more information about this file, see the man pages

ntp.conf(5), ntp_acc(5), ntp_auth(5), ntp_clock(5), ntp_misc(5), ntp_mon(5).

driftfile /var/lib/ntp/drift

Permit time synchronization with our time source, but do not

permit the source to query or modify the service on this system.

restrict default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery

Permit all access over the loopback interface. This could

be tightened as well, but to do so would effect some of

the administrative functions.

restrict 127.0.0.1
restrict -6::1

Hosts on local network are less restricted.

#restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

Use public servers from the pool.ntp.org project.

Please consider joining the pool (http://www.pool.ntp.org/join.html).

#server 0.centos.pool.ntp.org
#server 1.centos.pool.ntp.org
#server 2.centos.pool.ntp.org
#server 3.centos.pool.ntp.org
#server 0.south-america.pool.ntp.org
#server 1.south-america.pool.ntp.org
#server 2.south-america.pool.ntp.org
#server 3.south-america.pool.ntp.org
server 0.rhel.pool.ntp.org
server 1.rhel.pool.ntp.org
server 2.rhel.pool.ntp.org
server 172.16.25.9
#broadcast 192.168.1.255 autokey # broadcast server
#broadcastclient # broadcast client
#broadcast 224.0.1.1 autokey # multicast server
#multicastclient 224.0.1.1 # multicast client
#manycastserver 239.255.254.254 # manycast server
#manycastclient 239.255.254.254 autokey # manycast client

Undisciplined Local Clock. This is a fake driver intended for backup

and when no outside source of synchronized time is available.

server 127.127.1.0 #local clock
fudge 127.127.1.0 stratum 10

Drift file. Put this in a directory which the daemon can write to.

No symbolic links allowed, either, since the daemon updates the file

driftfile /var/lib/ntp/drift

Enable public key cryptography.

#crypto

includefile /etc/ntp/crypto/pw

Key file containing the keys and key identifiers used when operating

with symmetric key cryptography.

keys /etc/ntp/keys

Specify the key identifiers which are trusted.

#trustedkey 4 8 42

Specify the key identifier to use with the ntpdc utility.

#requestkey 8

Specify the key identifier to use with the ntpq utility.

#controlkey 8

Enable writing of statistics records.

#statistics clockstats cryptostats loopstats peerstats

Disable the monitoring facility to prevent amplification attacks using ntpdc

monlist command when default restrict does not include the noquery flag. See

CVE-2013-5211 for more details.

Note: Monitoring will not be disabled with the limited restriction flag.

disable monitor

2-Now on “nano /etc/asterisk/indicacionts.conf” I have this (what is after “#” is what was before)

[general]

country=ve

[ve]
description = Venezuela / South America
; Tone definition source for ve found on
; Reference: http://www.itu.int/ITU-T/inr/forms/files/tones-0203.pdf
ringcadence = 1000,4000
dial = 425
busy = 425/500,0/500
ring = 425/1000,0/4000
congestion = 425/250,0/250
callwaiting = 400+450/300,0/6000
dialrecall = 425
record = 1400/500,0/15000
info = !950/330,!1440/330,!1800/330,0/1000

#ESTO ESTABA ANTIGUAMENTE CONFIGURADO

#country=us

#[us]
#description = United States / North America
#ringcadence = 2000,4000
#dial = 350+440
#busy = 480+620/500,0/500
#ring = 440+480/2000,0/4000
#congestion = 480+620/250,0/250
#callwaiting = 440/300,0/10000
#dialrecall = !350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,350+440
#record = 1400/500,0/15000
#info = !950/330,!1400/330,!1800/330,0
#stutter = !350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,350+440

3-On “nano /etc/asterisk/extensions_additional.conf”, we added these lines

TIMEFORMAT = kM
TONEZONE = ve

4-We ran the command “ln -sf /usr/share/zoneinfo/America/Caracas /etc/localtime”

5-Checking “nano /etc/php.ini” on we wrote "date.timezone = America/Caracas

What more should we need to do in order for our phones to get the right time on the display?.

Thanks in advance.


(6 Taylor) #2

On part “1-” Everything on black is after a “#”…


(6 Taylor) #3

Keeping alive so anybody can help, please


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.