Time Conditions 13.0.22 - module named "cel" is required

We are using FreePBX 13.0.85

For a while now our FreePBX shows an update to the “Time Conditions” module.
However that update has a missing requirement “The Module Named “cel” is required.”.

I seem to not have a module called cel? And the only thing relevant I could find on google was a link an FreePBX/cel GitHub page.

Do I need to install the module from that GitHub page and if so how?

I’m seeing the same error

Upgrade framework. Then install call event logging

Thanks, that worked. Time Conditions is now up to date.

How do you do this? Sorry I can’t find the module to do that.

“Call Event Logging”

I mean upgrading the framework. And I don’t see any module “Call event logging”, or “Event logging”. I’m using asterisk 11.19.0 and Freepbx 13.0.95

Sorry to bother you but I would like to clean this up.


OK then, just point me to a page where I can do what you say (upgrade the framework), and whether I need to do that.


@jmmicmc You can’t use Call Event Logging on Asterisk 11, it’s not supported. You’ll need to upgrade to Asterisk 13 to use it and be able to install it.

Call event logging will install on 11 so that the correct files are installed and used. This is why time conditions requires it.

@tm1000 Ahh, good to know.

I’m still not ahead of things. I upgraded my framework via the cli and after doing that my aterisk version is the same. Same errors along with some errors about bad destinations.

So how do I proceed?


fwconsole ma upgradeall
fwconsole ma download cel
fwconsole ma install cel
fwconsole ma install timeconditions
1 Like

Thanks. I’ll do that!