Time condition and ring groups


(Suriname) #1

Hi,
I need help with an issue i am experiencing right now. The issue is that i have configured a ring group and a time condition. When there are regular office hours, the ring group should work where there are three ring groups. When the call is not answered by one ring group, the other ringgroup should ring. But Now it skips othe first ring group. It has worked well before. We have removed the time condition and placed the ring group only as default destination, but the issue si still the same. This has worked well before, but now it is causing issue. Can someone giveme advices how I can troubleshoot and solve this issue


(Lorne Gaetz) #2

Provide a call trace via pastebin
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Jared Busch) #3

Odds are no one in your first ring group is available.

Logs or we are just guessing.


(Suriname) #4

I could not recreate the situation. after configuring the tiem condition again, everything is working fine.
I do not understand what actually has happened


(Suriname) #5

Hey i am not guessing,
this is what the user has experienced. Now I can not recreate the issue to show yoy the logs


(Lorne Gaetz) #6

Full logs are kept for 7 days by default on the distro. The information you need may well still be available.


(Suriname) #7

ehm where can i get this full log?


(Lorne Gaetz) #8

Link provided above


(Suriname) #9

I have tried to get the log, but i don’t know why I am not getting it.


(Suriname) #10

One more thing had happened during the issue:


I don’t understand why we got this when restarting our freepbx


(Suriname) #11

I have directly copied the log from the server to the pastebin. I hope this can help us to find the cause of the issue. I am afraid that the issue will occur again.
Here is the link: https://pastebin.freepbx.org/view/a1f1f2af

you can look for 1623071169.1875 and further


(Itzik) #12

I tried finding such a line. I don’t see it.


(Suriname) #13

Hey, I think that is the issue also. there is no error debug. And the issue happened at that time.
But is there something else that you can see which can help me finding what exactly causes the issue?


(Simon Telephonics) #14

Are you asking the community to identify and solve an issue that you cannot reproduce and for which you have no logs?


(Suriname) #15

I thought I would able to see the issue in the logs, because if everything is logged in the freepbx. I should have been able to find what went wring at that time. Because I cannot reproduce it now. But that is not the point. If there was an issue, the time and the calls should be there. But they are not there.
So That means that there is one more issue.


(Suriname) #16

Here i am attaching a screenshot of the cdr. This is the time that the issue persisted. But I cannot debug this. I do not understand why. I am not even seeing this in the full log.


Do you have suggestions how I can find what exactly happened at the time that these calls were made.
I really want to know what happened


(Suriname) #17

And if you look at the suggestion of Igaets

I should have found the calls in the logs


(Andrew) #18

How did you generate the logs that are in the pastebin link you posted? Your screenshot of the CDR is for 9:34 am on 6/7 but the earliest the logs go on that day is 12:24 pm. The logs don’t contain the same time the calls occurred.


(Suriname) #19

Hey That is what I am saying,
I could not generate the logs. I have got this from the server and copied this to here. And I also do not understand why there are no logs for the time 9:34 am on 6/7. And i could not get the logs through the command line.
Do you understand what I mean?


(Andrew) #20

post the output of ls -al /var/log/asterisk/full*