There was an error updating the certificate

I’ve posted this before, but the post seems to be deleted with no explanation. Hopefully that’s a glitch and this is ok to post.

I am receiving this error:

There was an error updating the certificate: Error ‘Requested host ‘’ does not resolve to ‘’ (Found yy.yyy.yy.yyy)’ when requesting

In the error above, is my current IP address. The IP address it found, yy.yyy.yy.yyy, is a previous IP address of the server (We got a new ISP). It seems like the error is saying that the DDNS address ( is trying to direct to the old IP address. But my DDNS settings in system admin and on the Sangoma portal both point to the new IP address, I tried deleting the old certificate and tried creating a new one (using let’s encrypt) and I received the same error.

I’m far from an expert, but it seems like the deployment address from the DDNS service hasn’t updated to my new IP address.

Any idea how to fix this?

No you just need to search for them

Sorry about that. They weren’t showing up under my profile pic in the upper right. That’s generally where I go for updates.

They only show up there if someone has replied.

Thanks, Andrew. I’ll remember that moving forward.

I was looking into this some more, trying to figure it out. I have a directory /etc/asterisk/keys/ on my server. I deleted the Let’s Encrypt certificate in the GUI. Is this directory part of the Let’s Encrypt certificate? If so, is it possible a key in that directory is still referencing my old IP address? Should I delete that directory?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.