The Asterisk REST Interface is not able to connect please check configuration in advanced settings

I am seeing this message under asterisk info. Not sure what it means. Everything seems to function fine but it appears there was an update that changes the asterisk info page display a bit for online and offline status. Maybe it’s related or a bug? Anyone else seen this?

I am seeing the same behavior. Something changed within the last 48 hours or so. I updated two items today: blacklist and system version to “12.7.8-2302-1.sng7”.

Yes, I just logged into one of my systems and I see this message. When I have time I will check the others

Digging a little - from the Asterisk CLI window on a “working” system:

On my system which is throwing the error:

There appears to be a ARI user problem on the error system. Can anyone point me in the right direction to learn how to add “freepbxuser” to my ARI user list?

Thank you!

I did some additional work and learned something. Based on my system’s “?” username shown for ARI on the system with the REST error, I went looking for the proper way to reset this. I tripped over a posting about “Recent reports of ARI exploit on FreePBX systems (Recent reports of ARI exploit on FreePBX systems"”

This post detailed the couple of steps required to create a new ARI user and password as a step toward securing the server. I followed these steps. They properly created a new, randomly named, username within ARI. When I use the CLI and send ‘ari show users’, the new username is properly shown.

This did NOT solve the Asterisk Info report module REST problem.

So, then, I started matching line-for-line details on the “Advanced Settings” page. I confirmed that the REST interface was enabled. I then read the “help” notes for that field and they state that “This will enable the ARI server as long as the HTTP server is enabled as well”.

This pointed me to the section " Asterisk Builtin mini-HTTP server"

In this section, there is a field for “HTTP Prefix” . On my system with the REST error, there was a “0” (zero) value in this field. I did not see this value on another, working system. It was “blank”.

I removed the “0” from the field leaving it blank. I Submitted and committed this change.

And, now, the Asterisk Info Report properly presents the information without REST error.

So, removing the value in the “HTTP Prefix” field of the HTTP mini-HTTP server seems to have solved by issue.



Well, I was going through and changing all the ARI logins and passwords using the procedure in the FAQ referenced above - it’s working most of the time, but I am stuck on a machine that won’t let that error message go away - ARI is working, showing the correct user, and everything seems fine - but when I go into Asterisk Info, it just refuses - where is the disconnect with Asterisk Info and the actual ARI interface?

good answer,
my exact same issue was resolved like this

For anyone else having issues with Zulu restarting every second and not allowing user login; This resolved that issue for me. After removing the 0 from the “HTTP Prefix” field, Zulu became stable again and allowed users to connect.

Zulu was throwing “Can’t read swagger JSON” errors every second, crashing and restarting every time as well. Decided to give this a shot despite the issues being only closely related, worked like a charm.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.