System unusable after FreePBX 13 Upgrade

Hi all,
I’ve come across several attempts to upgrade FreePBX from 12 to 13 unsuccessfully, under custom FreePBX installs (no FreePBX Distro/in a flash).

  • OS = CentOS 6.7
  • FreePBX = 12.0.76
  • Asterisk = certified/13-cert2 & certified/13-cert7

There are 2 ways to upgrade FreePBX:

  1. Manually via CLI
  2. Using the “Upgrade 12 to 13 Tool” module

When upgrading manually:
After the three first steps (following this is what happens:

[[email protected] ~]# amportal a ma upgrade framework
Please wait…
Found module locally, verifying…Verified. Using Local
Module framework successfully downloaded
installing files to /var/www/html…done
installing files to /var/lib/asterisk/bin…done
installing files to /var/lib/asterisk/agi-bin…done
Checking for upgrades…No further upgrades necessary
framework file install done, removing packages from module
file/directory: /var/www/html/admin/modules/framework/amp_conf removed successfully
file/directory: /var/www/html/admin/modules/framework/upgrades removed successfully
file/directory: /var/www/html/admin/modules/framework/libfreepbx.install.php removed successfully
Generating CSS…Done
Module framework successfully installed
Removing any dangling symlinks
Dangling symlinks removed
[[email protected] ~]# fwconsole --fix_zend
-bash: fwconsole: command not found

If done via GUI (registered system), on step #3 the process breaks saying:

Submitting data to servers…Done
Running checks…Passed
Stage 1
Bumping FreePBX to version 13…Done
Checking online servers…Done
Downloading 13 Framework…Done
Installing 13 Framework…Done
ERROR: Try running this manually on the CLI to finish: ‘amportal && fwconsole ma upgradeall’

After the above, FreePBX ends completely broken. The ‘amportal’ command can’t se variables (directories) already present in asterisk configuration files, ge: ‘astrundir’ - PBX is bricked at this point.- Apache returns error 500.- ‘amportal’ is useless.- ‘fwconsole’ does not exist.

Running in the CLI the command suggested by the Upgrade Tool:

[[email protected] ~]# amportal && fwconsole ma upgradeall
Please wait…
astrundir in ‘/etc/asterisk’ is set to but the directory
does not exist. Attempting to create it with:
'mkdir -p ‘
mkdir: missing operand
Try `mkdir --help’ for more information.
Attempt to execute 'mkdir -p ’ failed with an exit code of 1
You must create this directory and the try again.
-bash: fwconsole: command not found


  • /etc/asterisk exists
  • /etc/asterisk/asterisk.conf exists
  • Everything was working until the failed upgrade attempt

After breaking our first PBX, we’ve tried several times with Virtual Machines: Every single time we get the same result.

Any ideas??

Hi! Thanks for coming over here instead of the wiki. It’ll make this process easier.

First lets start with a clean 12 system. Fully upgraded.

Then run:

amportal a m
update admin set value = '13.0.0alpha1' where variable = 'version';

Now make sure that the value in the admin table for version IS set to 13.0.0alpha1. Post here on the results but don’t move forward yet, please.

1 Like

Done so:

mysql> update admin set value = '13.0.0alpha1' where variable = 'version';
Query OK, 1 row affected (0.00 sec)
Rows matched: 1  Changed: 1  Warnings: 0

mysql> select * from admin where variable = 'version';
| variable | value        |
| version  | 13.0.0alpha1 |
1 row in set (0.00 sec)


amportal a ma download framework

Then cat /var/www/admin/modules/framework/module.xml

Here we go…

[[email protected] ~]# amportal a ma download framework

Please wait...
Downloading 8965940 of 8965940 (100%)            
Module framework successfully downloaded

Removing any dangling symlinks
Dangling symlinks removed

[[email protected] ~]# ll /var/www/html/admin/modules/framework/module.xml
-rwxrwxr-x 1 asterisk asterisk 18047 Jun 8 12:47 /var/www/html/admin/modules/framework/module.xml

[[email protected] ~]# cat /var/www/html/admin/modules/framework/module.xml

	<name>FreePBX Framework</name>
	<publisher>Sangoma Technologies Corporation</publisher>
		*13.0.131* FREEPBX-12289 remove all option
		*13.0.130* FREEPBX-12407 more sha256 work
		*13.0.129* FREEPBX-12474, FREEPBX-11117
		*13.0.128* Add support for database FULLTEXT
		*13.0.127* Clear statcache for FREEPBX-12460
		*13.0.126* FREEPBX-12460 no need to set permissions when deleting or removing
		*13.0.125* FREEPBX-12454 Dont set system locales if the locale does not exist (even the fallback)
		*13.0.124* FREEPBX-12405, along with drawselects restrictions
		*13.0.123* Actually fix FREEPBX-12259
		*13.0.122* FREEPBX-12259 FREEPBX-12170
		*13.0.121* Add new database migration support
		*13.0.120* Bug in current component
		*13.0.119* Fixes reloads stalling in Asterisk 13
		*13.0.118* Media conversion can be passed what it thinks are ico
		*13.0.117* FREEPBX-8768 add new component to allow quick picks
		*13.0.116* Dashboard overrides
		*13.0.115* FREEPBX-11223 Reload actually still breaks hints in AMI, workaround
		*13.0.114* FREEPBX-12256 Fix single line issues in modules.conf
		*13.0.113* Fix some astdb issues and gpg issues
		*13.0.112* FREEPBX-11223 fully resolve by preloading
		*13.0.111* Add new VoicemailRefresh AMI command for Asterisk 12 or higher
		*13.0.110* Issue a CLI 'dialplan reload' after startup and reload
		*13.0.109* Fully add back the functions
		*13.0.108* Add back fallback functions
		*13.0.107* FREEPBX-11992 Add visual notice that edge is enabled
		*13.0.106* Fix restart
		*13.0.105* FREEPBX-12019 run trim against any timezone setting
		*13.0.104* Fix broken stop start for modules
		*13.0.103* FREEPBX-12010 Dont track GPG of MOH files
		*13.0.102* Fix more issues in start/stop
		*13.0.101* The addition of the getSystemMemInfo function into the 'framework' module causes it to fail to run on FreeBSD systems. - lidl
		*13.0.100* FREEPBX-11852 Warn if module is disabled on fwconsole installed
		*13.0.99* Skip OOBE during popovers, since OOBE can have popovers
		*13.0.98* FREEPBX-11914 reblock stream when finished shutting down Asterisk
		*13.0.97* FREEPBX-11888 fix issue with installing local modules
		*13.0.96* Support new edge mode for module release. More details to come
		*13.0.95* Make sure asterisk files are owned by asterisk based user
		*13.0.94* Speed up install, adjust logic. Use fwconsole
		*13.0.93* Dont write to a logfile if we dont have permissions
		*13.0.92* Speed up install times
		*13.0.91* CLI mysql uses native STDs
		*13.0.90* Adjust notification message
		*13.0.89* Allow disabled or blocked modules to be upgraded
		*13.0.88* Hide errors that are irrelevant
		*13.0.87* Exclude folders in the symlink check
		*13.0.86* FREEPBX-11844 Symlink from modules failed
		*13.0.85* Fix notifications CLI and CLI Helper
		*13.0.84* Chown bin directory
		*13.0.83* Fix up ampuser to use private calls
		*13.0.82* FREEPBX-11564 fix visible extension range
		*13.0.81* Fix submitted patch to not break but continue
		*13.0.80* Support writing out stasis dialplan
		*13.0.79* FREEPBX-11809 report invalid timezones to dashboard
		*13.0.78* FREEPBX-11809 fix for newer php versions
		*13.0.77* FREEPBX-10571 colorize restart button in player
		*13.0.76* FREEPBX-11538 urlencode the filename for media playback
		*13.0.75* Add more flexibility to current component
		*13.0.74* Dont destroy a destination popover until after it's been closed so we get correct events
		*13.0.73* Visual changes to buttons
		*13.0.72* Move in browser recorder to framework
		*13.0.71* FREEPBX-11648 FREEPBX-11676 use datalist instead of unsupport js library
		*13.0.70* Dont sort a blank destination dropdown
		*13.0.69* Better restrictions on drawselects
		*13.0.68* Visual asjustments to popovers, cleanup and documentation for drawselects
		*13.0.67* Die_freepbx uses standard whoops error handler now. (Throws an exception)
		*13.0.66* Allow asking a specific media driver for its supported formats
		*13.0.65* Locate installed ASTAGIDIR correctly by lidl
		*13.0.64* Check loaded functions.incs on every module iteration
		*13.0.63* Resolve local dependencies as well as remote through cli
		*13.0.62* Addition of external modules
		** Look and feel changes (specifically wizards and play-seekers)
		** Framework should not depend on itself
		** FREEPBX-11494 "fwconsole chown" doesn't work in Kickstart script
		** Fix remote unlock compatibility issue
		*13.0.61* FREEPBX-11518 remove extension when cleaning up the filename
		*13.0.60* Case sensitivity matters in answers during install
		*13.0.59* FREEPBX-11523 Globally search for strings on install for included files
		*13.0.58* FREEPBX-11487 Create media dir if not exist
		*13.0.57* FREEPBX-11482 CDR_PROP to set
		*13.0.56* FREEPBX-11423 In asterisk 12+ use CDR_PROP instead of NOCDR, FREEPBX-11459 Add directory option to freepbx_chown.conf blacklist, FREEPBX-11466 Use framwork media method to determine mime type
		*13.0.55* FREEPBX-11437 fix chown hooks
		*13.0.54* Remove --full from chown. Only use the conf ignore file
		*13.0.53* Fixes FREEPBX-11417 missing full param
		*13.0.52* FREEPBX-11203 FREEPBX-11292 typo
		*13.0.51* Rare race condition
		*13.0.50* Change ASTVARLIBPLAYBACK to AMPPLAYBACK for consistency
		*13.0.49* Check for valid object in ami update before ami actions
		*13.0.48* Module getinfo fixes
		*13.0.47* Better Alert Info None select
		*13.0.46* Allow setable PHP timezone
		*13.0.45* Undo test work on menu.conf
		*13.0.44* Add custom select into advanced settings
		*13.0.43* Alert Info advanced settings tweaks
		*13.0.42* Support Alert Info drop down
		*13.0.41* FREEPBX-11058
		*13.0.40* Deal with spaces in file names in media parser
		*13.0.39* FREEPBX-10525
		*13.0.38* FREEPBX-11049
		*13.0.37* Asterisk cant make g719 formats, also wav49 shows up as WAV
		*13.0.36* FREEPBX-10986 FREEPBX-11001 FREEPBX-11002 FREEPBX-11003
		*13.0.35* FREEPBX-11050 FREEPBX-11058
		*13.0.34* Add functionality to call hooks outside of their parents
		*13.0.33* Add sorting engine for tables
		*13.0.32* FREEPBX-10956
		*13.0.31* FREEPBX-9793
		*13.0.30* FREEPBX-10842
		*13.0.29* FREEPBX-10863
		*13.0.28* FREEPBX-10909
		*13.0.27* Chown home directory
		*13.0.26* Correct tooltip for conferences application
		*13.0.25* Force Asterisk 11 to use sln16 even though it should support sln48
		*13.0.24* FREEPBX-10835
		*13.0.23* FREEPBX-10707 FREEPBX-10794 FREEPBX-10704
		*13.0.22* FREEPBX-10819
		*13.0.21* Dont compile assets that never change
		*13.0.20* Color changes
		*13.0.19* Add jquery form
		*13.0.18* FREEPBX-10611
		*13.0.17* FREEPBX-10682
		*13.0.16* Add json_last_error_msg()
		*13.0.15* FREEPBX-10744
		*13.0.14* FREEPBX-10715
		*13.0.13* FREEPBX-10573 FREEPBX-10576 FREEPBX-10715
		*13.0.12* FREEPBX-10557
		*13.0.11* Fix error during amportal restart
		*13.0.10* Add array_column polyfill
		*13.0.9* Hit escape to hide search and side floating bootnav
		*13.0.8* retweak navbar layout with search in a modular dropdown format
		*13.0.7* Ajax fix
		*13.0.6* Better right bootnav calculations
		*13.0.5* Fix module admin to fit within requirements
		*13.0.4* Bigger Search, new rnav design
		*13.0.3* Self-signed module and error correction in conf class
		*13.0.2* First stable release
		*13.0.1RC1.30* Remove broken symlink
		*13.0.1RC1.29* FREEPBX-10378 Only generate audio formats for current browser
		*13.0.1RC1.28* FREEPBX-10424 Escape quotes when writing to Asterisk Database
		*13.0.1RC1.27* Add RSS Parser
		*13.0.1RC1.26* Fix bad localizations
		*13.0.1RC1.25* Destination check requires a value but it can be blank
		*13.0.1RC1.24* FREEPBX-10406
		*13.0.1RC1.23* FREEPBX-10392 add default Charset to odbc.ini
		*13.0.1RC1.22* Prevent invalid entries in BMO ajax
		*13.0.1RC1.21* FREEPBX-5078 deal with numeric priorities correctly
		*13.0.1RC1.20* Fix Undefined index: highreleasetrackver
		*13.0.1RC1.19* FREEPBX-10337, FREEPBX-9107, FREEPBX-9111
		*13.0.1RC1.18* Avoid potential 'hostname: Unknown host' as part of PKCS
		*13.0.1RC1.17* FREEPBX-10310 shrink padding at user request
		*13.0.1RC1.16* Fix OOBE Button missing class, and no longer force people to go to dashboard
		*13.0.1RC1.15* Order of operators
		*13.0.1RC1.14* Add ability to supress toastr errors
		*13.0.1RC1.13* Case-insensitive version parse for ffmpeg
		*13.0.1RC1.12* FREEPBX-10255 Asterisk 13 deals better with sln conversions than Asterisk 11
		*13.0.1RC1.11* FREEPBX-10255 asterisk can only read 8k and 16k audio from sox
		*13.0.1RC1.10* Fix links for media libraries
		*13.0.1RC1.9* Media class should not die if it cant find a file
		*13.0.1RC1.8* During retrieve_conf check to make sure FreePBX can talk to Asterisk over the CLI as well
		*13.0.1RC1.7* Path separation issue
		*13.0.1RC1.6* fix which location check to have a fall back solution, have the media libraries use fpbx_which, add warning into retrive_conf if there are missing conversion libraries
		*13.0.1RC1.5* Deal with invalid module arrays from module xml descriptions
		*13.0.1RC1.4* Work around for missing ENT_HTML401
		*13.0.1RC1.3* Conf Update function should write readonly settings
		*13.0.1RC1.2* Secure paths
		*13.0.1RC1.1* Clean HTML5 playback cache every X days
		*13.0.1RC1* Release Candidate 1
		*13.0.1beta3.66* Fix permissions array when installing modules
		*13.0.1beta3.65* Add version tags to everything to force a refresh of assets
		*13.0.1beta3.64* Add fetchInto functionality
		*13.0.1beta3.63* Force date popups to be above other form items
		*13.0.1beta3.62* Sox can accept any wav file, add multi-select to components
		*13.0.1beta3.61* FREEPBX-10102 added slider to jqueryUI
		*13.0.1beta3.60* Support m4a files on importers
		*13.0.1beta3.59* Padding on global player
		*13.0.1beta3.58* If bootstrap_settings is not defined treat settings as true
		*13.0.1beta3.57* Remove session lock during html5 playback
		*13.0.1beta3.56* Media Updates
		*13.0.1beta3.55* Updates
		*13.0.1beta3.54* Blank array fix for loadConfig
		*13.0.1beta3.53* FREEPBX-10010 Wait up to 5 seconds for a response from Asterisk
		*13.0.1beta3.52* Revert FREEPBX-9972
		*13.0.1beta3.51* One off error in module.conf parsing
		*13.0.1beta3.50* FREEPBX-9972 LoadConfig doesnt understand multi-line settings
		*13.0.1beta3.49* FREEPBX-8630 Allow unlimited session timeouts for Local Admin
		*13.0.1beta3.48* Provide better debug and backtraces during chowns
		*13.0.1beta3.47* FREEPBX-9916 based on evidence provides in said ticket add set_time_limit in PKCS class
		*13.0.1beta3.46* Bad regular expression match
		*13.0.1beta3.45* More work on installer
		*13.0.1beta3.43* FREEPBX-9897 installer doesn't correctly detect asterisk status
		*13.0.1beta3.42* Remove PHP warnings
		*13.0.1beta3.41* No need to check for installdir
		*13.0.1beta3.40* Add check for Pear getopt and move a few more files into place
		*13.0.1beta3.39* Revert changes from beta 3.37
		*13.0.1beta3.38* Fix some less permission errors
		*13.0.1beta3.37* Remove duplicate includes
		*13.0.1beta3.36* FREEPBX-9841 Fix permissions during retrieve_conf, FREEPBX-9862 remove developer notice, FREEPBX-9863 add signature file into installer
		*13.0.1beta3.35* Remove improperly placed IE 9 if tag
		*13.0.1beta3.34* Shrinkable action bar
		*13.0.1beta3.33* FREEPBX-9808 fixes invalid array
		*13.0.1beta3.32* FREEPBX-9798 move gotoEmpty to the only class that uses it
		*13.0.1beta3.31* FREEPBX-9795 Fix warnInvalid to work with improperly made tabs
		*13.0.1beta3.30* FREEPBX-9790 ksort wants an array so only give it that
		*13.0.1beta3.29* FREEPBX-9775 invalid loops
		*13.0.1beta3.28* Numerous changes and corrections. FREEPBX-9713
		*13.0.1beta3.27* Invalid menu looping
		*13.0.1beta3.26* Move method to proper place
		*13.0.1beta3.25* Fix fix_zend to work around error handler
		*13.0.1beta3.24* Dont fall through after fwconsole update, add old session conversion
		*13.0.1beta3.23* Check for valid symlinks on all chowns
		*13.0.1beta3.22* Use proper env location and revert to using older command in install()
		*13.0.1beta3.21* Lock form submitting to only visible forms
		*13.0.1beta3.20* Improve individual module loading
		*13.0.1beta3.19* Adjust chowning to lookup symlinks, adjust button sizing, more dynamic menus
		*13.0.1beta3.18* Fix chowning to use the full path, then chown twice
		*13.0.1beta3.17* FREEPBX-9668 Multiple issues with FreePBX 13 Custom Extensions
		*13.0.1beta3.16* FREEPBX-9662 Module Admin rollback broken in 13
		*13.0.1beta3.15* json ability in module admin on the CLI
		*13.0.1beta3.14* Modify includes in fwconsole ma to not include zended files
		*13.0.1beta3.13* Dont run chown after module install if not root
		*13.0.1beta3.12* Invalid Array looping
		*13.0.1beta3.11* FREEPBX-7999 regular expression fix
		*13.0.1beta3.10* Proper check for zended files
		*13.0.1beta3.9* Allow changing PHP Error logging
		*13.0.1beta3.8* stop resetting error reporting levels
		*13.0.1beta3.7* FREEPBX-9519 Tooltip issues resolved
		*13.0.1beta3.6* Library fix
		*13.0.1beta3.5* Update and shrink libraries
		*13.0.1beta3.4* FREEPBX-9533 remove reference to unutilized function
		*13.0.1beta3.3* Update hooks after we have run through our installs for all modules
		*13.0.1beta3.2* Warn on coding errors, don't enable faulty modules
		*13.0.1beta3.1* fix to loading older files
		*13.0.1beta3* Dont package one script
		*13.0.1beta2* Order of arguments
		*13.0.1beta1* This is beta 1, there will be many more betas after this
		*13.0.1alpha72* Add BMO function to get all Destinations from
		*13.0.1alpha71* Fixes to search tool
		*13.0.1alpha70* Tab scroll improvements
		*13.0.1alpha69* Speed up retrieve conf
		*13.0.1alpha68* new font, better styling, format jquerui to match
		*13.0.1alpha67* Bring back old header sizes, fix styling in sortables, adjust action icons
		*13.0.1alpha66* Update bootstrap to the newest version, remove reset.less
		*13.0.1alpha65* FREEPBX-9438 edit the extension settings error
		*13.0.1alpha64* Add modern broswer detection, throw exception instead of die_freepbx() in ext-splice
		*13.0.1alpha63* Extension map checking when numeric
		*13.0.1alpha62* Fixes permissions and styling
		*13.0.1alpha61* Fix jqueryUI centering issues
		*13.0.1alpha60* Verbose GPG errors
		*13.0.1alpha59* Fix fatal when using invalid cookie
		*13.0.1alpha58* Fix installlocal
		*13.0.1alpha57* Fix error handling when in CLI or ajax mode
		*13.0.1alpha56* Standardize layouts
		*13.0.1alpha55* Small tables when in mobile or restricted views
		*13.0.1alpha54* Database wrapper cleanup and localize database errors
		*13.0.1alpha52* Fixes and improvements
		*13.0.1alpha51* Bootstrap table fixes
		*13.0.1alpha51* Chown fixes
		*13.0.1alpha50* New jquery and jquery-ui
		*13.0.1alpha49* Try catch additions in retrieve_conf
		*13.0.1alpha48* Fix retrieve conf so that it generates files
		*13.0.1alpha47* Check if a valid array as well
		*13.0.1alpha46* Include jquery wizard and styles for it
		*13.0.1alpha45* Current component invalid array fixes
		*13.0.1alpha44* Namespace issues
		*13.0.1alpha40-43* Undefined indexes fixes
		*13.0.1alpha39* Fixes errors with bad arrays
		*13.0.1alpha38* Error Handler no more white screens, php console, other fixes!
		*13.0.1alpha37* Notifications fixes
		*13.0.1alpha36* Fixes to signature signing
		*13.0.1alpha35* Fixes to page submitting
		*13.0.1alpha34* Backport in OOBE updates
		*13.0.1alpha32* Add chosen and multiselect to global javascripts
		*13.0.1alpha31* Bubble up tab switches from lower level items
		*13.0.1alpha30* FREEPBX-9002 Trigger event on successful completion of Apply Config, FREEPBX-8998 Invalid group when updating ring group 0
		*13.0.1alpha29* Prep first offical UTF8 release
		*13.0.1alpha28* FREEPBX-8984 OOBE fails because path is staticly set
		*13.0.1alpha27* FREEPBX-8984 OOBE path fixes
		*13.0.1alpha26* Language updates
		*13.0.1alpha25* Dont redeclare the less class
		*13.0.1alpha24* Chown Class fixes
		*13.0.1alpha23* DB class connect method addition
		*13.0.1alpha22* Fixed issue with modules extending gui elements
		*13.0.1alpha21* cant only have comments in else statements of bash scripts
		*13.0.1alpha20* FREEPBX-8953 sticks navbar to top of page.
		*13.0.1alpha19* Fixes to inputs
		*13.0.1alpha18* Fix module admin
		*13.0.1alpha17* During class_exists() checks dont run autoloaders
		*13.0.1alpha10-16* Installer fixes and tweaks
		*13.0.1alpha9* Display message in the GUI if the autoloader is malfunctioning
		*13.0.1alpha8* New CLI command, --fix-zend which fixes broken zended files
		*13.0.1alpha7* On install update LESS cache. Fix upgrade installer
		*13.0.1alpha6* Set moh correctly, permissions
		*13.0.1alpha5* Prettify installer. Hopefully fix issues
		*13.0.1alpha4* Fix getAssoc in DB wrapper, cleanup installer
		*13.0.1alpha3* Escape all of the exceptions, fixes to installer as well
		*13.0.1alpha2* First attempted release. Complete visual overhaul using bootstrap. Action buttons on every page. Global search functionality. Namespace everything. Using core PHP symfony technologies. Replacement of installer, replacement of amportal.
		*13.0.1alpha1* Removed depreciated PearDB.
		This module provides a facility to install bug fixes to the framework code that is not otherwise housed in a module

Version is 13.0.131

ok now:

amportal a ma install framework

[[email protected] ~]# amportal a ma install framework

Please wait...
installing files to /var/www/html..done
installing files to /var/lib/asterisk/bin..done
installing files to /var/lib/asterisk/agi-bin..done
Checking for upgrades..
2 found
Upgrading to 13.0.1alpha1..
-> Running PHP script /var/www/html/admin/modules/framework/upgrades//13.0.1alpha1/upgrade.php
Upgrading to 13.0.1alpha1..OK
Upgrading to 13.0.50..
-> Running PHP script /var/www/html/admin/modules/framework/upgrades//13.0.50/upgrade.php
Upgrading to 13.0.50..OK
framework file install done, removing packages from module
file/directory: /var/www/html/admin/modules/framework/amp_conf removed successfully
file/directory: /var/www/html/admin/modules/framework/upgrades removed successfully
file/directory: /var/www/html/admin/modules/framework/start_asterisk removed successfully
file/directory: /var/www/html/admin/modules/framework/install removed successfully
file/directory: /var/www/html/admin/modules/framework/installlib removed successfully
Generating CSS...Done
Module framework successfully installed

new amportal script detected, copying it to /usr/local/sbin and attempting to backup up old
Creating symlink for fwconsole
Removing broken fwconsole link
!!!!amportal is depreciated. Please use fwconsole!!!!
forwarding all commands to 'fwconsole'

[[email protected] ~]# which fwconsole

Well, that didn’t happen before!
I see the only different thing we tried here is to avoid the ‘amportal a ma upgrade framework’, but run first the download, and then the install commands separately. Nice :slight_smile:

So next we should go for:

fwconsole --fix_zend
fwconsole ma upgrade core
fwconsole ma disable backup
fwconsole ma download backup
fwconsole ma install backup


Yes but amportal a ma upgrade framework wouldn’t have made a difference. You can check this yourself. upgrade simply runs download & install

Correct, and that’s what I did before with the same VM at the same snapshot we worked together today.
Whenever I ran ‘amportal a ma upgrade framework’ it went south, but with ‘amportal a ma download/install framework’ it didn’t :confused:

Now the new thing is with fwconsole:

[[email protected] ~]# fwconsole --fix_zend ; echo $?
[[email protected] ~]# fwconsole ma upgrade core ; echo $?

… and it will keep that way…

I dont know where the error code of 255 would be coming from.

Have you tried running just fwconsole? Do you have custom code on this system? or custom modules?

fwconsole’ alone does nothing.

[[email protected] ~]# fwconsole 
[[email protected] ~]# echo $?

Nope, no custom code nor custom modules at all.

Something on your system is killing php in a very bad way. Not sure what that would be. You’ll have to go into the code and do troubleshooting or provide us with a way to connect to your machine.

I dont think this is an issue but Im curious what these two return:

php -v
mysql --version

[[email protected] ~]# php -v

PHP 5.3.3 (cli) (built: May 10 2016 21:39:50) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

[[email protected] ~]# mysql -V

mysql Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86_64) using readline 5.1

If you want to provide us access please PM me with the details to connect to your system

That’s a very old version of PHP, and that may be causing your problems.

andrew thankyou for the instructions you provided here. I had the ‘fwconsole: command not found’ problem and your help in this thread sorted it out for me.


I’m having some issues with upgrading 12 to 13 and it appears to be related to release Any ideas how I can move past this?

Checking for upgrades…
7 found
Upgrading to 13.0.1alpha1…
-> Running PHP script /var/www/admin/modules/framework/upgrades//13.0.1alpha1/upgrade.php
Upgrading to 13.0.1alpha1…OK
Upgrading to 13.0.50…
-> Running PHP script /var/www/admin/modules/framework/upgrades//13.0.50/upgrade.php
Upgrading to 13.0.50…OK
Upgrading to 13.0.143…
-> Running PHP script /var/www/admin/modules/framework/upgrades//13.0.143/upgrade.php
Upgrading to 13.0.143…OK
Upgrading to…
-> Running PHP script /var/www/admin/modules/framework/upgrades//
Upgrading to…OK
Upgrading to…
-> Running PHP script /var/www/admin/modules/framework/upgrades//
Upgrading to…OK
Upgrading to…
-> Running PHP script /var/www/admin/modules/framework/upgrades//
PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Attempted to load /var/www/admin/libraries/BMO/ModulesConf.class.php but it didn’t define the class ModulesConf’ in /var/www/admin/libraries/BMO/Self_Helper.class.php:210
Stack trace:
#0 /var/www/admin/libraries/BMO/Self_Helper.class.php(100): Self_Helper->loadObject(‘ModulesConf’)
#1 /var/www/admin/libraries/BMO/Self_Helper.class.php(36): Self_Helper->autoLoad(‘ModulesConf’)
#2 /var/www/admin/libraries/BMO/FreePBX.class.php(84): Self_Helper->__get(‘ModulesConf’)
#3 /var/www/admin/modules/framework/upgrades/ FreePBX::__callStatic(‘ModulesConf’, Array)
#4 /var/www/admin/modules/framework/upgrades/ FreePBX::ModulesConf()
#5 /var/www/admin/modules/framework/installlib/installer.class.php(148): include_once(’/var/www/admin/…’)
#6 /var/www/admin/modules/framework/installlib/installer.class.php(109): FreePBX\Install\Installer->install_upgrade(‘’)
#7 /var/www/admin/modules/framework/install.php(211): FreeP in /var/www/admin/libraries/BMO/Self_Helper.class.php on line 210


Guys usually sysadmin module is provided in freepbx 13 manual installation on centos 6 which is not supported anymore and In my last conversation with freepbx support team they disabled system admin module to use with manual installation and after doing some changes by the guy I won’t able to connect with the gui anymore so please make sure if you have gone for the installation with system admin module on manual installation then you may be not able to load back the gui after module upgradation.

hi Andrew
have the same situation
do U have solution
thanks in advance