Superfecta ConnectWise lookup fails

Hi,

when setting up the ConnectWise superfecta loopup, it fails with no matches and the following message:

‘{“error”:{“type”:“Whoops\Exception\ErrorException”,“message”:“Undefined variable: debug”,“file”:"/var/www/html/admin/modules/superfecta/sources/source-ConnectWise.module",“line”:203}}’

Can anyone help me out?

cheers!

Did you double check your settings for your configuration of ConnectWise on the data source section? Make sure the API Version is correct as well?

Yes, I took the API version from the web-url after logging in to the web-based connectwise site…
Not sure if that’s the right one though…

Have you tried the other API?

Hi James,

what other API?
I’ve tried v2016_6 as the quistion mark sugested, as that is my current version of CW.
I’ve also tried v2014_4, just to be sure. All give the same output.

I meant the v2016_6. I thought you were trying v2014_4. I’d say next try to reinstall CID Superfecta and start over on it. If it doesn’t work I’d try a support ticket then honestly as I haven’t seen this issue before.

Looks like a bug. Locate the file:
/var/www/html/admin/modules/superfecta/browse/sources/source-ConnectWise.module

Locate line 203 and change from:

else if($debug) {

to:

else {

If that works, file a bug report at http://issues.freepbx.org with this fix.

No more errors :smiley: but a test lookup is not returning a name from CW.
Is there anyway to see the output of the lookup?

You can adjust the debug verbosity when testing Superfecta lookups.

I know…the Debug/Test Run Scheme is telling me that the the number is not found in CW.
I’m however 100% sure that the number is there. Can we simulate the seach from cli to see all output / web query output?

I know this is an old post however, I just ran across this issue. I’m running Superfecta 13.0.4.2 on freepbx 13.0.192.19, Connectwise had been working for a year or so. I just noticed that it was no longer pulling info so I tested and ran across this exact error. Took out the if($debug) and now we are back in business. All tests work and I see info being pulled from both contacts and compaines now.

1 Like

Hi Andrew,

that is not working…still no lookups that return a company or contact.
Any idea how to debug?

Thanks!

Did anyone report this as a bug?

I didn’t. Not sure if it is a bug, if we can debug the query we can try to solve it.

Cheers

Anyone ever figure out how to get the Connectwise lookups to work?

1 Like

Needed to create an integrator login then it all worked! The next issue how to pass this to the zulu softphone.

Can you explain the steps? Thank you.

@lgaetz @kirkhenry Posted bug here: https://issues.freepbx.org/browse/FREEPBX-15891?filter=-2

Thanks.

Get it working?

Nada, Amigo.

But…I have not edited the module either… Is that what you did though, as well as setup an integrator login?