Stuck at Loading all FreePBX modules

Have tried multiple times to install 4.211.64-5/6 on a server. I am trying to install it with Asterisk 11 and get the following after the Anaconda install

Please wait while we install FreePBX GUI
This can take anywhere from 5-10 minutes
… Enabling Asterisk modules
… Loading all FreePBX modules

From here it won’t proceed, I have even waited overnight. I have also moved it to another subnet as I read it could be network related and am trying to rule that out.

I believe I got it to work with Asterisk 1.8, I am going to try Asterisk 10 now. If I press CTRL + ALT + F1 I can see information but can’t do anything. The last few lines are

STARTING PBX FIRST BOOT
Starting on console 8, myconsole = 1
exec > /var/log/pbx/install/firstboot.log

  • exec
    exex 2>&1
  • exec

I was able to grab that log ones, the end has the following

Untaring…Done
Module sysadmin successfully downloaded
package sysadmin is not installed
Unable to determine sysadmin rpm version…continuing
Successfully copied LoadLicenseIfExists.php.
mv: cannot stat `/var/lib/asterisk/agi-bin/license-*.zl’: No such file or directory
Listen 80
which: no lsof in (/sbin:/bin:/usr/sbin:/usr/bin)
/usr/bin/which: no lsof in (/sbin:/bin:/usr/sbin:/usr/bin)
sh: -i: command not found
sh: -i: command not found
sh: -i: command not found
sh: -i: command not found
sh: -i: command not found

We are looking into this.

Ok can you try to run the following for me from the linux cli and paste back the output:

rpm -q --qf “%{VERSION} %{RELEASE}\n” sysadmin

Also are you upgrading this system using an upgrade script or is this a new install?

I am doing a new install using the ISO. I just tried and selected Asterisk 10 instead of 11 and it worked. I didn’t get a chance to try with the stuck Asterisk 11 one.

Let me reinstall with Asterisk 11 and see what it does.

Looks like it is stuck with Asterisk 11 again. So it seems like 1.8 and 10 work but for some reason not 11.

[[email protected] ~]# rpm -q --qf “%{VERSION} %{RELEASE}\n” sysadmin
package sysadmin is not installed

Confirmed network connectivity, I can ping google and 4.2.2.2. I also installed on a VM and it worked fine so I dunno what the deal is. Should I just install with Asterisk 10 and switch to 11 after that?

This was my bad, previously I was installing via virtual CD through a DRAC. I burned to a DVD and the install succeeded.

The problem appears to be that the SystemAdmin module is not getting installed. This started a couple days ago. I am installing Asterisk 11 32bit.
The server just sits at the “Loading all FreePBX modules” on the console. However, you can access the web interface and SSH.
I fix the use I do a yum install sysadmin.

Sorry for the typos.
To fix the problem, I putty into the server. Then I run yum install sysadmin. This installs the module that is causing the install to not complete. Then go into the Module Admin through the web gui and upgrade the System Admin. Reboot the server, and the console will load all modules and reach the login prompt.

Hi

Thank you for your post. I am having the same issue setting up from the ISO using ver 11. This is the second time I’ve attempted to install ver 11 recently. I am installing to a virtual machine running on KVM. Gets stuck exactly as described by jibberjabber above. This last installation, I did not have internet access while the install was running and was instructed to run /etc/pbx-first-boot after I had access. It was during this stage that the issue described above occurred.

Hopefully this could shed some light on reproducing the issue.

Please advise if you have any more insight.

P.

papparomeo,
What version of the ISO are you using?

I was building the server from CD ISO directly on the console.

Stable-3.211.63-10
Release Date-06-02-13
FreePBX 2.11, Centos 6.3
Asterisk 1.8, 10 or 11

I am trying a install of 3.211.63-10 as we speak.

Ok, think I have this figured out. You should be able to continue using your existing ISO images (as this was an issue during our first boot which requires network connectivity).

The sysadmin module will not automatically install the sysadmin rpm it requires to function. As a result it will error out and tell you to yum install sysadmin if the version it requires is not already installed. After the latest module is installed you should be able to return to module admin and install the sysadmin freepbx module.

@jibberjabber,
Just to make sure I understand correctly, the issue was only happening for you if you installed through the DRAC and only for one version of asterisk, which was 11. Is that correct? Just trying to make sure I have enough info to see if we can replicate it.

I’ve been stuck with the latest 64bit FreePBX distro.
Kept it that way for more than 4 hours.

Here’s a screenshot:

the version of freepbx that elastix uses isn’t a real freepbx you can’t expect any real stuff to work. try for help in their forums

Hi dicko, as outlined - I’m talking about FreePBX distro. Not Elastix. :slight_smile:

Then stop saying . . .

“FreePBX 2.8.1.4 (as part of the Elastix framework 2.2.0-22)”

and instead say what hardware platform you are using and how your network/routers are configured.