Strange bridging of incoming calls

I have a system with 4 FXS modules and 8 FXO modules sitting on 3 TDM400 cards. I have several IP phones as well. Each one has it’s own extension.

The strange issue I’m facing is, some calls coming in through the FXO module bridges to the highest FXS module before connecting to another FXS module or the IP phone. As such, the caller ID that gets sent is the user assigned to that FXS module.

Incoming calls going through the FXO module should be connected directly to the correct FXS module or IP phone, shouldn’t it?

I hate to say this, but that’s gibberish 8) You’re saying the caller ID is set incorrectly when you receive a call? Make sure that callerid=asreceived is set in each FXO port in /etc/asterisk/zap*.conf

–Rob

Let me rephrase my question

When a caller calls in, the caller needs to enter an extension to talk to someone.

Sometimes, the call bridges directly from the FXO module to the proper extension (either an FXS module or IP phone). When this happens, the caller id that gets sent to the destination extension is the correct one.

However, there are many times when the the call bridges from the FXO module to the highest numbered FXS module (in my case, FXS module # 4), and then bridges from FXS #4 to the proper extension. When this happens, the caller id that gets sent to the destination extension is that of the agent that’s on FXS #4 (so it looks like the agent on FXS #4 is calling the destination extension, and not some external caller ID number)

I hope that’s a better explanation of my problem.

I’m just not sure why the extra bridge is created between the caller and destination extension (via FXS #4) instead of bridging directly from the FXO module to the destination extension.

It seems to happen at random, and isn’t affected by which FXO module the call comes in through.

[quote=“phantaszm”]When a caller calls in, the caller needs to enter an extension to talk to someone.
[/quote]

So your inbound route goes to an IVR with direct-dial enabled… OK.

I don’t like your use of the word ‘Bridge’, as that has an internal asterisk meaning that has nothing to do with Caller ID or ports (it’s to do with codec translation, and confuses a lot of people - I’ve changed the word ‘bridge’ here to ‘connect’)

So, in the logs you’re seeing it do a Dial(Zap/4)? That’s pretty much nuts, and I can’t see how that could happen.

I still think that it’s a callerid=asreceived issue in your zapata.conf files… But, the best thing to do is paste a log of the call getting the wrong caller ID to pastebin.ca, and then harass someone on #freepbx to help you (I’m usually there)

–Rob