SSH into freepbx distro


(Mitch) #1

Hi,

I have installed the latest version of FreePBX. But I can’t seem to access the server via SSH.
First of all, I temporary disabled iptables and made sure sshd is started. Now I’m able to connect, but with every access atempt, I get an access denied. I know root is limited, so I enabled permit root lgon in the ssh config.

I also tried creating a new user in shell, and use that user to login, but it gives the same access denied error.

Is there something i’m overlooking to gain SSH acces? Is SSH disabled by default in the distro?

Thanks!


(Bob Reiber) #2

Did you do something like turn off password authentication or install some dsa/rsa keys that you’re forgetting about? Did you change the SSH port from the default (Settings -> Advanced Settings most of the way down it says Non-std SSH port)?

If you’re getting access denied how are you getting in at all? Make sure that the root password you’re using is the same as the one you entered when you installed FreePBX.


(Mitch) #3

Hi,

Thanks for your reply

No, I did not change anything except the steps I have described above. It is just the standard distro install. I can connect to ssh, but can’t authenticate.
I don’t see the “SSH port setting” in advanced settings, but since I can connect to port 22, I guess its ok.

I can login with my root password on the via the VM console without issue. So I’m sure my password is working and is correct.


(Bob Reiber) #4

Can you get into the GUI? Are you sure you have an IP address? It should be obvious when you log into the console, the first line below the giant FREEPBX is eth0 IP. If there is nothing there try ifup eth0 , or go to /etc/sysconfig/network-scripts/eth0 and give it an IP.


(Mitch) #5

Hi,

I have an IP for sure. The whole system (and the gui) works as should. I am actively using freepbx now with 4 sip phones and a couple of trunks, IVR’s etc. So everything works perfect.
I also can connect with SSH. So IP/port/firewall is not an issue. But I can’t authenticate with SSH. So it just says my username and pw are wrong (while i’m 100% sure it is not).


#6

Check Fail 2 ban (intrusion detection) under the sys admin module. If your IP is listed as blocked stop and restart fail2ban and try again. Another thought, could this be a NAT or packet filtering issue? Are you on the same subnet as your PBX?


(Rummings) #7

I think I am having the same issue? Did anyone ever solve this?
I can SSH in but the password is always wrong and I get access denied.
The password works in the GUI.


#8

For SSH you need to use your root password that you set when you installed the system
For the GUI, that would be the one you set when you installed FreePBX


(TheJames) split this topic #9

6 posts were split to a new topic: SSH Password reset


(TheJames) closed #10