[Solved] Yealink VoIP phone will not register


(Moussa) #1

I have a Yealink phone (T46S) that all the sudden stopped registering. As a background, the phone was working before, I tried to change SIP to PJSIP (did not work, so) back to SIP. The IP was blocked by fail2ban (I then unbanned the IP). All phones on the same IP location are working fine. The same extension (200) will work if is used by different IP phone at the same location. A new extension was created will work on a different IP phone but not the Yealink phone. Below is the log from before and after the issue. I did factory reset for the Yealink phone, still will not register.

Any idea what to do?

[2019-09-27 03:40:34] SECURITY[2793] res_security_log.c: SecurityEvent="ChallengeSent",EventTV="2019-09-27T03:40:34.692-0400",Severity="Informational",Service="SIP",EventVersion="1",AccountID="200",SessionID="",LocalAddress="IPV4/UDP/x.x.x.x/5060",RemoteAddress="IPV4/UDP/x.x.x.x/5060",Challenge=""

[2019-09-27 03:40:34] SECURITY[2793] res_security_log.c: SecurityEvent="SuccessfulAuth",EventTV="2019-09-27T03:40:34.716-0400",Severity="Informational",Service="SIP",EventVersion="1",AccountID="200",SessionID="",LocalAddress="IPV4/UDP/x.x.x.x/5060",RemoteAddress="IPV4/UDP/x.x.x.x/5060",UsingPassword="1"



[2019-10-01 11:56:27] SECURITY[3045] res_security_log.c: SecurityEvent="ChallengeSent",EventTV="2019-10-01T11:56:27.688-0500",Severity="Informational",Service="SIP",EventVersion="1",AccountID="200",SessionID="",LocalAddress="IPV4/UDP/x.x.x.x/5060",RemoteAddress="IPV4/UDP/x.x.x.x/5060",Challenge=""

(Itzik) #2

Assuming you arw provisioning the phone, check the /tftpboot folder and delete all files related to that phone’s MAC and then rebuild via EPM


(Moussa) #3

Thank you, @PitzKey. We just have few phones, so we manually provision them. I took the phone to another location and it successfully registered. In addition to the different network, I used direct power to start the phone vs PoE+. Tomorrow, I will see if the phone will work in the first location using direct power. Thanks again, Itzik.


(Moussa) #4

Things are back to normal :slight_smile: .
Two changes that I made: 1) I have pfBlockerNG installed on pfSense to block ads and malicious activities on WAN and LAN. The rules were cleared. 2) The NAT Mode for that extension was set to No so I changed it to Yes (my system is offsite.)


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.