Solved: Outbound calls failing on trunk


(Fraxx) #1

Hello all. I have an issue where outbound calls fail instantly with a ‘busy line’ message on a trunk over which inbound calls work fine. The PBX has another trunk to an SBC and inbound/outbound calls work. I’ve used the same configuration for both, inbound and outbound rules also. Both trunks go over dedicated L2 circuits - no registration involved.

The 20959901 extension belongs to a range allocated to us by the remote party. The 20930315 extension is a valid extension on the remote PBX. Calls from 20930315 to 20959901 are routed and end on my own extension on my PBX correctly (inbound rule works).

On outbound I see a ‘500 Internal Server Error’ message. The vendor of the remote system says that my INVITE is missing the CDPN and should be formatted “sip:user[at]host” as a minimum.

I’m rather new to FreePBX and Asterisk and I have not been able to find a solution. I really hope someone can help.


TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 21 - failing through to other trunks
(Joshua C. Colp) #2

I don’t do FreePBX, but the configured outbound proxy is incorrect. It needs “;lr” at the end of it to ensure the request is loose routed. In configuration file that would just be done by adding “;lr” to the end of the outbound_proxy. I don’t know what it looks like in FreePBX land.


(Fraxx) #3

Sir, many thanks for your help.

I edited the outbound proxy to sip:80.xx.xx.xx;lr and disabled force rport on the trunk. The call went out successfully.

I searched and read and tried tons of edits on the trunk w/o result for two weeks.

Again, many thanks for your time and expertise.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.