[SOLVED]Mysterious Router problems

Hi There

I’ve setup a freepbx system (with asterisk 11 and freepbx 2.11 ). All is working very well expect external extensions. I’ve forwarded all required port on our router (UDP: 5059, 5061 and 10000-20000; TCP 5059).
If I call my external phone it rings and I can hang-up or take it, put it on hold, but there is no sound in both directions.
And now the strange is, if I enable “general NAT” on our Router (all trafic is routed to the pbx) it works fine.

I enabled RTP debug via CLI and the output with NAT enabled:

Sent RTP packet to (type 00, seq 043640, ts 2863235832, len 000160)
Sent RTP packet to (type 00, seq 023606, ts 3591295144, len 000160)
Got  RTP packet from (type 00, seq 021514, ts 1829640586, len 000160)

Without NAT enabled:

Sent RTP packet to (type 00, seq 053218, ts 2877308328, len 000160)
Got  RTP packet from (type 00, seq 004265, ts 2877308495, len 000160)

So, whats wrong here, is the fault off our Router or is it an other thing? Maybe its using a port that I didn’t forwarded?

Technical background: is my softphone on my PC / is my mobile phone, connected via mobile network (I think with NAT44 )
PBX: yes the singnalingport is 5059

And here are the settings from freepbx:

Many thanks for your help.


OK. Problem solved. Our Router had problems forwarding such huge a range of ports. I’ve split-up the range to smaller ranges. Now it works like a charm :smiley:

1 Like