[solved] MOH While Dialing Extension from IVR Instead of Ringing


I have an issue similar to this one:

I’ve slightly modified the advice given here by adding the dial string tm(MusicOnHoldClass) to the Extensions “Asterisk Dial Options” and selected the Override button since I want this regulated to only a certain group of extensions:

What I’m trying to accomplish is that when this group of extensions are dialed whether from another extension, but most importantly direct dialed from the IVR or directory, this particular music on hold class is played as opposed to ringing.

  1. I add the dial string tm(MusicOnHoldClass) to the Asterisk Dial Options for the extension
  2. Select Override from the Asterisk Dial Options option on the extensions page
  3. Submit, Apply Config and restart FreePBX amportal restart

But all to no avail. When I dial the extension directly from the IVR or from another extension, I still get ringing as if my Asterisk Dial Options override is being ignored (the default dial options in General Settings is what is displayed in the CLI). Is there something that I am doing wrong or need to check?

Please advise. Thank you!

System Information:
PBX Firmware: 5.211.65-19
PBX Service Pack:
Asterisk 11.10.2

The simplest way to do this was for me to add FollowMe to each extension, and have instead of “Ring” it go to the MOH class. This worked and continues to work great. I’d like a more elegant option where if it’s internal, no MOH, and only external calls get the MOH, but for now, noone is complaining.