[SOLVED] ERROR MESSAGE when installing FREEPBX on Centos 7 - Not ASterisk User

After installing Asterisk and then attempting to install FREEPBX this is the message I get


STARTING ASTERISK
Asterisk is already running
[[email protected] freepbx]# ./install -n
Assuming you are Database Root
Checking if SELinux is enabled…Its not (good)!
Reading /etc/asterisk/asterisk.conf…Done
Checking if Asterisk is running and we can talk to it as the ‘asterisk’ user…bash: line 0: cd: /home/asterisk/: No such file or directory
Error!
Error communicating with Asterisk. Ensure that Asterisk is properly installed and running as the asterisk user
Asterisk appears to be running as asterisk
Try starting Asterisk with the ‘./start_asterisk start’ command in this directory

It appears it wants me to run the ./start -n command as the asterisk user. How do I change users?
I already ensured asterisk is running

killall -9 asterisk

Try starting Asterisk with the ‘./start_asterisk start’

I tried your killall command

[[email protected] ~]# killall -9 asterisk
-bash: killall: command not found

I did try the the start again

[[email protected] freepbx]# ./start_asterisk start

STARTING ASTERISK
Asterisk is already running

You have no asterisk home directory. You probably didn’t create it when you created the Asterisk user.

Would you mind telling me the correct way to create the asterisk home directory?

adduser asterisk -M -c "Asterisk User"

This is what I get

[[email protected] ~]# adduser asterisk -M -c "Asterisk User"
adduser: user ‘asterisk’ already exists
[[email protected] ~]#

ls -l /home/asterisk

[[email protected] ~]# ls -l /home/asterisk
ls: cannot access /home/asterisk: No such file or directory
[[email protected] ~]#

mkhomedir_helper asterisk

You are amazing. It worked. Thank you very much for your help

1 Like

As you obviously have little knowledge of CentOS, the better answer here would be to not install on your own instance and to always use the full, distro ISO. It will move up to 7 with FreePBX 14 and you stay in 100% known territory for getting support from people.

It is great you got it figured out this time, but it will almost certainly happen again.

You are correct I do have little knowledge of Centos. I would love to use the Distro but I do not have physical access to the server in Chicago, so I have to use wget commands to load applications and software. Once I learn how to load a distro remotely I will do that.

Thank you for your input and help - it is appreciated.

Your server should be virtualized, so there is no question that you can have console access to a VM.

If you did not virtualize, then do that first.