Skip VM password using *97 on pjsip

Under the Voicemail settings for my extension, I’ve set the option to skip the password if I’m dialing *97 from my own extension. However, it’s still asking for my password. I suspect this is an incompatibility with pjsip?

NoOp(“PJSIP/103-000000b8”, “Channel PJSIP/103-000000b8 is NOT 103 forcing VM Password”) in new stack

This is not relevant to pjsip

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs

Is this helpful?

https://pastebin.com/raw/SmrpgvB9

Here’s your problem:

[2018-04-25 10:21:52] VERBOSE[17362][C-000000bd] file.c: <PJSIP/103-000000e8> Playing 'vm-password.ulaw' (language 'en')
[2018-04-25 10:21:59] WARNING[17362][C-000000bd] app_voicemail.c: Unable to read password

It is prompting your for a password, but doesn’t appear to be receiving digits from you.

See my first post in this thread. I don’t want it to prompt me for digits. :wink:

I see here

[2018-04-25 10:21:52] VERBOSE[17362][C-000000bd] pbx.c: Executing [*[email protected]:117] NoOp(“PJSIP/103-000000e8”, “Channel PJSIP/103-000000e8 is NOT 103 forcing VM Password”) in new stack
.
.
.

Possibly still a pjsip thing ?

I sure would like to say that I was right and that it’s a pjsip issue… you know, stick it to the devs! What do they know anyway? All they do is create this awesome software and give it to us for free…

But, umm, it looks like some dumb user (me) must have unintentionally changed a setting. I was comparing my working extensions to my non-working extension and happened to notice that under the Advanced tab of the extension there is a “Dial” option that was set to “PJSIP/103,” – yes, with the comma at the end. I suspect I fat-fingered that in there when modifying the mailbox monitoring, which is the next option on the screen. The description of the “Dial” setting reads: “How to dial this device, this should not be changed unless you know what you are doing.” Oops. :smirk: I have no idea what that setting actually does – the phone could make and receive calls with seemingly no issue – but it did break this minor “no password for *97” feature.

Problem resolved!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.