Skip busy agent yes not working in queue on 13.29.2 [resolved]

Migrated to a server on asterisk 13.29.2 from 13.23.1, now when extensions are on a queue call or direct call, queue calls still ring to the extensions. I have tried both:
Skip Busy Agent = Yes
Skip Busy Agent = Yes + (ringinuse = no)

In the past I have had luck with one or the other, has anyone else run into this on 13.29.2 and resolved it without a downgrade?

Under the actual extension, do you have the state set to use state?

Thanks for the reply. Yes, it is set to Use State under the advanced tab of the extension.
Device State Busy at is blank, Iā€™m not sure if that was blank before or was 0 previously and if that matters?

I tested Device State Busy to 0, I am still seeing the same issue, calls continue to ring to the agent.

After Testing with an old Cisco Spa phone, skip busy agent works correct. However, the bria softphone still does not abide by the skip busy agent option (which it was on the pbx running 13.23.1). I am going to roll back asterisk to 13.23.1 on the new server and report in after I test again.

I hope you are aware that Asterisk 13 is beyond end of life.

1 Like

Upgrading to freepbx 16 did not work due to php issues with third party software.

Rolling back to asterisk 13.23.1 resolved this issue.

Rolling back to an even older EOL asterisk version is a work around, not a resolution. What version of FreePBX are you using, are you able to change to a current supported version such as Asterisk 16 or 18?

Freepbx 13. As I noted we tried to migrate to freepbx 16, however there were major hurdles with asternic software when trying to upgrade by that route.

Pick the Asterisk Version you would like to change to.
        Press 1 and the Enter key for Asterisk 11
        Press 2 and the Enter key for Asterisk 13
        Press 3 and the Enter key for Asterisk 14 (Currently in beta)
        Press 9 and the Enter key to exit and not change your Asterisk Version

This is after running yum upgrade asterisk-version-switch