SIP trunk etisalat UAE

Hello all,
my telecome provider etisalat / UAE has installed a sip trunk in my office. i use freepbx .
the trunk works perfectly with xlite however i cant seem to be able to register using freepbx.
these are the settings for xlite.
userid:XXXXXXXXX
domain:YYYYYYYY.etisalat
displayname:XXXXXXXXX
authorization name:YYYYYYYYY.etisalat
password :ZZZZZZZZ

Domain proxy settings: register with domain and recieve calls checked
send out bound via proxy address : PROXY_ADDRESS_STATIC_IP

inside topology:
range of ports used for signaling :5060-5061
firewall traversal: auto

insnide advanced:
use rport
send sip keep alives

i would like to get some help if posible from someone to map the xlite coniguration to a proper freepbx configration

thank you all :slight_smile:

So you are saying you can successfully register your trunk to your provider, but you can’t register your xlite client to your PBX?
Are your PBX and your xlite client on the same network?

hello @avayax
i am actually saying the opposite.
i cant register with my provider using xlite but i cant do it using my pbx because i don’t know how to configure the trunk properly in freepbx .
my provider gives me an Ethernet port . when i connect to it using my laptop and xlite it works, ie i can register with my provider
.
but through my pbx it seems that i am doing something wrong with my authentication

what would my config be for freepbx based on the above xlite config?

Usually each provider requires slightly different setting with Asterisk.
They should give you the exact FPBX trunk settings if you request it from them.
Here is a sample configuration:
https://wiki.freepbx.org/display/FPG/Trunk+Sample+Configurations

Yes that assuming they are a good provider. I have another provider that gave me all the details like the sample you provided. It took me two minutes only and it works like a breeze.

All they said is they will give me config for xlite only and they aren’t responsible for any other system.

What I am looking for is , since xlite is working fine, is it possible to translate that config to an actual freepbx config like in the example?

OK. If you can post the XLite configuration, we should be able to “translate” it for you. The settings are pretty simple, even though the language changes a little from time to time.

hi, below is the working config for xlite, i highly apprieciate it

userid:XXXXXXXXX
domain:YYYYYYYY.etisalat
displayname:XXXXXXXXX
authorization name:YYYYYYYYY.etisalat
password :ZZZZZZZZ

Domain proxy settings: register with domain and recieve calls checked
send out bound via proxy address : PROXY_ADDRESS_STATIC_IP

inside topology:
range of ports used for signaling :5060-5061
firewall traversal: auto

insnide advanced:
use rport
send sip keep alives

hello @cynjut ,
do you think it is possible to translate that xlite config to free pbx config? peer user and regstration string? the problem is that they only support xlite ;(

Should be relatively simple:

Your PEER settings should look something like this:

host=PROXY_ADDRESS_STATIC_IP
type=friend
username=YYYYYYYYY.etisalat
secret=ZZZZZZZZ
context=from-trunk
disallow=all
allow=alaw
dtmfmode=rfc2833
Insecure=invite,port

You shouldn’t need a registration string, but if you do, it will look like this:
YYYYYYYYY.etisalat:[email protected]_ADDRESS_STATIC_IP

The catch is that you may be fighting a bigger battle than you think. Since they only support X-Lite, I doubt you’ll be able to really use this effectively for FreePBX.

@cynjut
Thank you very much for your effort.
i finally figured it out with some help from wireshark and your own translation. i will post the configuration below for everyones benefit

host= PROXY_ADDRESS_STATIC_IP
type=peer
qualify=yes
fromdomain=YYYYYYYYY.etisalat
fromuser=XXXXXXXXX
realm=etisalat.com
username=YYYYYYYYY.etisalat
context=from-pstn
auth=YYYYYYYYY.etisalat
disallow=all
allow=alaw
secret=ZZZZZZZZ
insecure=port,invite

registration string > [email protected]:ZZZZZZZZ:[email protected]_ADDRESS_STATIC_IP:5060/XXXXXXXXX

no need for user details

You can change the type from “peer” to “friend” and anything that would have been handy in the user segment carries over (“Friend” equals “Peer+User”).

In your case (especially if it’s working), I wouldn’t mess with it.

hmm , well i tried to change it to friend, doesnt seeem to have any affect at all. am a little confused

In your implementation, I wouldn’t expect it to do much. The idea is that “friend” sets up both Peer and User modes in one configuration entry. Since you’re not using any “User” entries, it’s overkill for you.

1 Like

thanks for the hint :slight_smile:

hello all

i managed to register my etisalat sip trunk, and i also managed to make a route but when the route reaches etisalat i says the “number you have dialed is incorrect” like my pbx dials the wrong number

any help plz

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.