SIP port changes

I have faced a issue, my carrier provider using 5060 port for calling, due to lots of hit from outside world in freepbx in well known port 5060, I have changed 5060 to 6060 sip port. But as my voip provider using 5060 no incoming calls come to my freepbx whenever I changed to port 5060 to 6060. So how to achieve the same, I want to change the well known port 5060 to some different port and incoming calls should work.

If your SIP Provider only sends to 5060, then lock it down. No other way around it AFAIK.

Or, setup your PBX to use 6060. And set a NAT rule which only applies on traffic from your SIP Provider to translate 5060 to 6060.

It’s probably a good time to mention that 5060 is for “incoming” traffic only, so you and your provider can, provided there’s an interface for negotiation, set the inbound port on each of your systems to whatever value you want to use. If they want to use 5060, you send traffic to them on 5060. If you want to use 12345, you should be able to set that in their end to point to your system.

The only reason anyone actually uses 5060 is tradition. There’s no technical reason why it can’t be something else.

Thanks for help, may I use two port 5060 and 6060 at a time. and some specific ip will only use 5060 other than all use 6060, as a example " allow port number 5060 other than all ip who try to hit on 5060 will deny, and any ip 6060 port is allowed ". As I am using cloud server there is no concept for lan or wan all in public ip, no nat concept as per my knowledge.

Depends. You can only redirect the incoming ports from 5060 to 6060 on your router, but you can only associate one port at a time with a specific SIP service you are using.

There is a way to do this by setting up different SIP drivers - the defaults on the system now are 5060 for PJ-SIP and 5160 for Chan-SIP.

I’m not sure how to redirect you from here, so I’ll just be blunt. Depending on how the cloud server is set up, I’m pretty sure LAN and WAN still mean the same things they always have. Your cloud server is still on a local cluster somewhere and will certainly have a LAN address. The WAN address is going to be the address that the rest of the Internet (or the Wide Area Network).

Without learning a lot more about your setup, whether you use NAT or not is going to be installation specific.

Now, in your original post, you said your provider wants you to send them calls on port 5060 and you want your provider to send you calls on port “something other than 5060”. There is not in that statement that requires any advanced understanding or special rules. Set up your incoming port to 6060 and reconfigure your address entry for your ITSP to send all of your SIP traffic to “300.300.300.1:6060” (where 300.300.300.1 is your server’s WAN address. In the Integrated Firewall, all the ITSP’s server address(es) through the firewall by making them “trusted” networks.

You sending your phone traffic to their 5060 address is completely unrelated to them sending your traffic on port 6060.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.