Sip-phones correctly registered but no sound

configuration
freepbx
Tags: #<Tag:0x00007f70279feb08> #<Tag:0x00007f70279fe950>

(Vladimir HOUZANME) #1

Dear,

Please give me a hand to well-configure 2 SIP-Phones Planet VIP-256PT on FreePBX Server 14 (with axterisk 13).

I have created 2 extensions (phone numbers) on the FreePBX System, and have to applied each extension on a different SIP-PHONE Planet VIP-256PT.

Below all the configurations on the Server and on each sip-phone PLANET.


SERVER CONFIG :

IP : 192.168.1.10

PORT : 5060

Codecs : ALaw, ULaw, G.729,G.723,G.722

NB: codecs are set in this order.

Two extensions created : 200, 201


PHONE 1 : Config

SERVER ADDRESS : 192.168.1.10

PORT SIP : 5060

ACCOUNT : 200

Codecs : (in this order)

G.711A

G.711U

G.729

G.723

G.722


PHONE 2 : Config

SERVER ADDRESS : 192.168.1.10

PORT SIP : 5060

ACCOUNT 201

Codecs : (in this order)

G.711A

G.711U

G.729

G.723

G.722

Both phones (Planet VIP-256PT) are registered on the FreePBX système, but none of them is giving sound (NO SOUND).

If on the first sip-phone (200) and try to call the second-one (201), the call cames and rings, but if taken and talk, i can not hear anything.

Please help me. Maybe something is wrong in the configurations.


#2

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set.
Based on what you have said so far, Local Networks should be
192.168.1.0 / 24

If you change these settings, you must restart (not just reload) Asterisk.

If the above is not your issue, as the Asterisk command prompt, type
pjsip set logger on
or
sip set debug on
according to the type of extensions you created.
Then, make a (failing) test call and paste the relevant section of the Asterisk log at https://pastebin.freepbx.org and post the link here.


(Vladimir HOUZANME) #3

How can i get to Asterisk command prompt ?

Just the root prompt when physically on the FreePBX ?
Or
Do you refer to this : fwconsole pjsip set logger on ?
Because i use PJSIP and i can confirm you tomorrow (when at office) about Asterisk Settings (external address and local networks) you Ask.

Thanks a lot dear friend, if there is possibilities we can directly write on WhatsApp.


(Sergio Lobera) #4

So internal calls are not working either ?
Silly question (it happened before): Are you sure you are not connecting the handset into the headset jack ?


(Vladimir HOUZANME) #5

Handset is not connected to headset jack. I still get the same problem.


(Sergio Lobera) #6

Phones are on the same network ? 192.168.1.0/24 ?
Anyway, take a look at Asterisk SIP Settings > Local Networks.
Add all your local networks with their mask there as you can see on this image


(Vladimir HOUZANME) #7

My friend Steward1, let me come back to you in few minutes.
Someone advice me ti type this command Line : yum update (it’s running). I will try the command you advice me (fwconsole pjsip set logger on).

But i want to confirm the settings on :
Settings/Asterisk SIP Settings (NAT Settings)
- External address : my static internet address (giving by my internet proviseur)
- Local networks : 192.168.1.0/24


(Vladimir HOUZANME) #8

Thanks for your image. But here, both ChanSIP ans PJSip are not enabled (in your image i can see that PJSip is enabled ans ChanSip is not)

it’s not possible for me to activate PJSip (General Settings / Security Settings / Default TLS Port Assignment) ?


(Vladimir HOUZANME) #9


(Vladimir HOUZANME) #10

Please still have the same problem. Could you please tell me what is the problem ?


(Sergio Lobera) #11

That’s the default TLS port assignment so it’s ok if you don’t have it enabled.
Try to make a call to *43 with your speaker

If the phone is registered, and it’s on the same network, using the same codecs you have enabled on your PBX, should be working.


(Vladimir HOUZANME) #12

The device are registered on the FreePBX.

When i hit *43 it marks “connected” and shows time going.


(Sergio Lobera) #13

Did you try to use the phone’s speaker ?
Try this:

  1. Unplug one of your phones
  2. Download Zoiper or any other softphone on your computer
  3. Use the unplugged phone’s extension on that softphone and make a call, see if that has audio.

(Vladimir HOUZANME) #14


(Sergio Lobera) #15

I don’t understand @vhouzanme
Try with what I proposed you above.

  1. Unplug one of your phones
  2. Download Zoiper or any other softphone on your computer
  3. Use the unplugged phone’s extension on that softphone and make a call, see if that has audio.

(Itzik) #16

Can you please do the below?