Since upgade to SNG7, Zulu is stuck disabled, pending upgrade to 14.0.27

Since my upgrade to SNG7, Zulu somehow stayed at and disabled.
Pending upgrade to
If I try to upgrade, it gives me an unable to upgrade error.
If I try to enable, Module zulu cannot be enabled.
If I try to uninstall, Failed to run un-installation scripts.
If I try to reinstall:
Enabling PJSIP Websocket server
Unable to enable websocket driver!
Unable to install module zulu:
- Failed to run installation scripts

Any ideas?

asterisk -rx 'module load'

asterisk -rx 'module show like res_pjsip_transport_websocket'

asterisk -rx ‘module load’
Unable to load module
Command ‘module load’ failed.

asterisk -rx ‘module show like res_pjsip_transport_websocket’
Module Description Use Count Status Support Level
0 modules loaded

That is your #1 issue. You need to go and enable the channel driver “both” in advanced settings. Then restart Asterisk and run my commands again.

hmm… I had the channel driver on both since it prompted me initially when I attempted the upgrade.
I had only reloaded FreePBX at the time, I went ahead and just restarted the OS to be sure.

I get the same error when running “asterisk -rx ‘module load’”:
Unable to load module
Command ‘module load’ failed.

However when I run “asterisk -rx ‘module show like res_pjsip_transport_websocket’” I get the following:
Module Description Use Count Status Support Level PJSIP WebSocket Transport Support 0 Running core

Restart asterisk and Zulu should install after that

sweet! that worked. Thanks again!

I am having a similar issue, but when I make sure that in advanced I have “both” selected then run those commands and restart asterisk I get no love. I do however get this output:

fwconsole ma install zulu
Updating tables zulu_interactions_interaction_states, zulu_softphones, zulu_tokens, zulu_interactions_contacts, zulu_interactions_interactions, zulu_interactions_members, zulu_interactions_streams, zulu_interactions_stream_bodies, zulu_interactions_stream_links, zulu_login_tokens…Done
Enabling the Asterisk ARI Server

In utility.functions.php line 207:

trying to set keyword [ENABLE_ARI] to [1] on uninitialized setting::

Not similar at all

fwconsole ma downloadinstall arimanager

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.