FreePBX | Register | Issues | Wiki | Portal | Support

Setup Sip Trunk With UCOM Provider from Armenia

configuration
Tags: #<Tag:0x00007f749e69bc38>

(Arman Baghajyan) #1

HI.

I decided write this post, because I spent whole week trying to setup trunk with Ucom Armenia SIP provider and couldn’t find any information about configuration with outbound proxy. Finally, I set up the trunk and it works great.

I had used chan_sip for trunk.

For general tap in trunk setup page.

Trunk Name - SomeName
Outbound CallerID - YourPhonNumber given from Ucom

Outgoing Sip Settings

username=Username/PhoneNumber from Ucom
fromuser=Username/PhoneNumber from Ucom
secret=SECRET
host=(outbound proxy domain name)
outboundproxy=(outbound proxy domain name)
fromdomain=(domain name)
port=5060
type=friend
context=from-trunk
insecure=port,invite
trustrpid=yes
sendrpid=yes
directmedia=no
qualify=yes
keepalive=45
nat=yes
dtmfmode=rfc2833
disallow=all
allow=ulaw

Incoming Sip Settings

User Context - Username/PhoneNumber from Ucom

username=username
type=friend
secret=SECRET
qualify=yes
port=5060
outboundproxy=outboundproxy
nat=yes
insecure=invite,port
host=outboundproxy
dtmfmode=RFC2833
context=from-trunk

Register String
Username@domainname:secret:username@outboundproxydomainname/username


(Dave Burgess) #2

I know you have this working, so I don’t recommend changing it “just because you can”, but if you find yourself in a situation where you are changing things, you should be able to make a few changes to this. The simplest is, since this is a “type=friend” setup, you can remove all of the User Context stuff since it’s duplicated by the “friend” type.


(Arman Baghajyan) #3

Thanks for giving suggestion.

I hand an other issue. I cant call to local county codes. I haven’t setup dial patterns, I just set .(dot) as dial pattern, and able to call local mobile providers but cant call to local country codes.

This is the logs

For local mobile numbers
Working

-- Called SIP/Ucom_trunk_main/098XXXXXX

Retransmitting #1 (NAT) to PIP.PIP.PIP.PIP:5060:
INVITE sip:098XXXXXX@outboundproxydomain:5060 SIP/2.0
Via: SIP/2.0/UDP IP.IP.IP.IP:5060;branch=z9hG4bK16e15299;rport
Max-Forwards: 70
From: sip:37460XXXXXX@domainname;tag=as26af44e2
To: sip:098XXXXXX@outboundproxydomain:5060
Contact: sip:37460XXXXXX@IP.IP.IP.IP:5060
Call-ID: 25827a4244b372641a085b833620ae0d@ims.ucom.am
CSeq: 102 INVITE
User-Agent: FPBX-14.0.5.25(13.22.0)
Date: Wed, 20 Mar 2019 13:22:40 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Remote-Party-ID: “37460XXXXXX” sip:37460XXXXXX@domainname;party=calling;privacy=off;screen=no
Content-Type: application/sdp
Content-Length: 252

For local country codes
NOTWorking

-- Called SIP/Ucom_trunk_main/010XXXXXX

<— SIP read from UDP:PIP.PIP.PIP.PIP:5060 —>
SIP/2.0 502 Bad DNS Request 040351915
Via: SIP/2.0/UDP IP.IP.IP.IP:5060;received=IP.IP.IP.IP;rport=5060;branch=z9hG4bK6171efef
To: sip:010XXXXXX@outbounddomainname:5060;tag=h7g4Esbg_p65541t1553088093m831164c76419074s1_2149794546-1998362588
From: sip:37460XXXXXX@domainname;tag=as1b3a99e7
Call-ID: 1f0ded4c7db0113a653b097425e180bf@ims.ucom.am
CSeq: 102 INVITE
Contact: sip:sgc_c@PIP.PIP.PIP.PIP;transport=udp
Server: Ericsson MTAS - CXP9020729/8 R14D01
Supported: timer
Content-Length: 0


(Dave Burgess) #4

You need to set up the dialed-number-modifiers in the Trunk as well as setting up the Outbound Route. What kinds of edits have you applied to those to get this working?

This looks important. Check your configuration for misspelled hostnames (if you are using hostnames). You should consider using IP addresses for your connectivity - it reduces the delay DNS injects into the process and makes for fewer “missed” DNS errors.


(Arman Baghajyan) #5

PIP - provider ip

I have changed domain to ip and now I am getting this

Got SIP response 500 “Destination Unreachable 040351923” back from PIP.PIP.PIP.PIP:5060


(system) closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.