Settings > Advanced Settings > Backup Module - missing


#1

Hi

I cant find this settings in the Adv. settings

PBX Firmware: 5.211.65-14

Any Ideas?

Thanks!


#2

Has it been installed or removed? Backup and Restore comes under your Admin Tab 3 or 4 down depending on your installation options. If it is not there, goto module admin, again ader the admin tab and install it. It could be disabled or it might have been uninstalled.


#3

Yes. I tried that. Still no Backup module settings in the Adv. settings…


#4

I also upgraded to 5.211.65-15… Same :frowning:


(Preston McNair, ClearlyIP CRO) #5

There is an advanced settings module, and a separate backup module, that shows under admin menu, not advanced settings.


#6

Im not sure that you understand the issue :wink:
I want to set the “from” email asdress for a backup job… this settimg is located in the adv. Settings. In my case… no such option is avilable and nackup related emails are sent from root@localhost.local…

Any other ideas?


(Preston McNair, ClearlyIP CRO) #7

Your right I didn’t understand neither did anyone else as this is the first time you mention the back up email address.

I just checked a system still running the same version as you, and that setting is in the advanced menu. It likely has hooks into the Backup module (not sure) you do have that module installed correct?


#8

Sorry fot not being clear :wink:
And yes. All looks and act as mormal. Kust that setting section in the adv. Settings is missing… ;(


#9

I should imagine but I don’t know, when installed maybe some permissions was wrong and it did not get installed?. Did you try removing the backup module and reinstalling it? I don’t mean just uninstall, uninstall it then go into /var/www/html/admin/modules and delete the backup module. Go back into module admin, download and install and see if it is back.

If it helps, my permissions for mine show the following…

Group: Asterisk
Owner: Asterisk

Octal: 0770 for the modules folder and I believe all other folders in that directory are or have different permissions, my folder for the backup is octal: 0775.


#10

Same - still no oprion in the adv. settings ;(


(CHZone) #11

Just did a brand new install over the top of a previous release. Then restored from backup. So I have FreePBX 15 latest distro and all is well … except I do not have the BAckup option available in Advanced Settings. I need this in order to change the email address info. I have uninstalled the Backup and Restore module then re-installed but no change. The backups run OK just the option to change the from email via the Advanced Settings is missing. Does anyone have any idea how to get it?


(Lorne Gaetz) #12

I see it on my system in Advanced Settings. What version of the backup module are you running?

[root@pbx ~]# fwconsole ma list | grep backup
| backup               | 15.0.8.86  | Enabled  | GPLv3+      |

(CHZone) #13

The same version. I have another system which is fine. Just this one is odd for some reason.


(CHZone) #14

Does anyone know if there is a way to reload the module using the CLI? I would hope that this may be more likely to fix the problem.
Or …
Another alternative is to edit the specific file were the from ‘address’ info is set. Does anyone know which file should be modified?


(Dave Burgess) #15

Yeah, you should be able to reload the config file as well as reloading the module.


(CHZone) #16

Tried downloadinstall of the backup module using fwconsole but no change in behaviour. For whatever reason the Backup option in Advanced Settings is not available.

Does anyone out there have any idea why this would be so given this was a fresh ISO installation about two weeks ago. The only additional step was to restore a previous config from an earlier version. Would this cause the loss of this particular capability?