Set Static IP on Sangoma Phones *** RESOLVED***


#1

Hello!

I saw this topic posted here:https://community.freepbx.org/t/phones-keep-changing-network-settings-to-dhcp/56010

No one was able to help, the problem resolved itself without any explanation and the thread descended into chaos. I have the same question. Every once in a while, my DHCP service stops on my server and all my systems lose their addresses. It would be nice to have my phones statically assigned so we can continue to process calls.

I have tried changing to static via the GUI, the phone’s direct interface (menu>network…). The phone reboots and goes back to DHCP. The only thing I can get to work is to change the EPM setting to GUI override (instead of config). Will I lose the rest of my configuration I’ve done through EPM if I go that route?


#2

Generally DHCP servers don’t just stop because they just reply to requests, so what are you using for said service?

Are you absolutely sure that you have ONLY one DHCP server running on your network?


#3

Thank you, dicko for responding. I am using Windows Server 2016 Standard. It is somewhat unpredictable, but I think it actually fails to start during reboots following updates. I have to have a third party restart it because I don’t know how. In the meantime, we’re phoneless. Most of my other network connected devices are set up statically because of this. I can’t seem to figure out how to make the phones’ settings “stick.”

Absolutely is an absolute term :slight_smile: but I am sure there is only one DHCP server on the network (Windows Server 2016). I have disabled the DHCP settings on my router and the FreePBX server is not acting as a DHCP server either.


#4

You can see any traffic with

tcpdump -vvnn port 67 or port 68

Perhaps Windoze is a bad choice?


#5

If you have a third party restarting the service for you then they are administering your server. Theoretically they are being paid to do this. If so, it’s their responsibility to fix the issue. The DHCP service on the server should not need manual start, that’s not normal. If they can’t fix it find someone who will or move the DHCP service to the router or something more reliable.


(Greg Blumenthal) #6

@clintonvets there was a phone firmware fix made in this area back in 2019, I’m not sure if it stemmed from the topic you mentioned, but the description seems to match pretty well :
https://wiki.freepbx.org/display/PHON/Phone+Firmware+Release+Notes

X.0.4.72

September 20, 2019

  • Issues Resolved:
  • Correct failure to properly parse provisioning of a static IP

The internal description of the related bug reads “When the S505 phone is configured with a static IP, then pointed to the PBX at http://ip:84/ for provisioning, the phone reboots without its static IP (menu > status > information > ipv4: 0.0.0.0)”. If that sounds like a match for what you’re seeing, a phone firmware upgrade may be in order


#7

I’m part way there. I’m starting with my own phone (an S406). I rolled back the firmware to x.0.4.72. Now it’s set to static but won’t accept the ip address I want to use. When it reboots, the ip address is 0.0.0.0. Now, I can’t get it to set back to DHCP - upon reboots and factory resets, it remains at static with the address 0.0.0.0.

I made a typo once and that ip address remained (197.168.x.x instead of 192.168.x.x), but it won’t use any of the healthy number of ip addresses that I tried (that are on my network) for a static ip.
I rolled up to the latest firmware and still can’t get it back to where it was. (now it doesn’t work at all)

Any thoughts?


#8

The problem of those telephones was never resolved, and instead we went with another manufacturer.


(Jared Busch) #9

Do what you were told previosuly and make your support comapny fix their DHCP server.


(Greg Blumenthal) #10

Just to clarify, I didn’t mean to suggest you roll back your firmware to X.0.4.72, was only suggesting to make sure you were on X.0.4.72 or later (so as to get the “Correct failure to properly parse provisioning of a static IP” fix). Best to use the latest firmware (absent some known issue with the latest, and I don’t think that applies here). If you were already running something later than X.0.4.72 then my suggestion yesterday isn’t relevant.


#11

I have resolved the issues to my satisfaction. Windows Server and DHCP issues aside, I was able to get one of my phones to accept a static IP address by making setting the IP as a different network, rebooting, and then correcting the error. It works now and I’m satisfied. For those who have suggested fixing the DHCP server, we are working on that problem. Thank you, community, for participating in my thread!


(system) closed #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.