FreePBX | Register | Issues | Wiki | Portal | Support

Phones keep changing network settings to DHCP


#1

In the Web GUI, it is set as Static IP address. The Base Config file has P8 set to 1 for Static (changed from 0), and I have ended up changing “GUI Override” setting to GUI in the End Point Manger template, but the phones still keep booting with DHCP. enabled.

What else can be done?


(Jared Busch) #2

I can say anything about the setting not sticking, but why not just use DHCP?

Seriously, why do you need the phones to have a static IP? Endpoints (of any kind, computer, phone, whatever) should not need that kind of control. It just makes more work.


#3

You never heard of site requirements?


#4

And servers too?

So NO, I disagree, vehemently :slight_smile: , knowing and controlling where everything is IMHO a real good policy on any serious network. It’s not ‘work’ it’s management.


(Tony Lewis) #5

It should work but feel free to open a support ticket if it’s not. As far as policy yes knowing the IP is good but most people use DHCP reservations for that reason not setting static that way anytime you factory reset your settings will not be lost.


#6

But if you care to, most DHCP servers allow you to “reserve” and award IP addresses in their range by MAC address (which is unlikely to change :wink: ) which might be a “work-around”.

Of course you will need a DHCP server on the network which is also an added “support” need in it’s own right.


#7

Well, two of the phones all of a sudden magically switched to static IP addresses, but with no IP assigned. Odd since I was messing around with DHCP and the provisioning should not of switched to static since the EPM was set for GUI settings.

I am sorry, but I think these brand of phones have serious issues.

I hope support can fix them.


(Tony Lewis) #8

I am sorry you feel that way about them. I am sure comments like that will get you lots of help from people. Not sure why they work fine for hundreds of thousands of other users just fine. Things don’t just magically change. I do not understand what your changing or not changing but on a Friday night at 7pm I took time to test this and it worked fine for me so not sure why they do not for you but that is why you get free support on them. Go work with support but I suggest checking your attitude at the door before you engage with support.


#9

After spending time to set them on a in network which was a near duplicate of the network where they would be moved to, including the PBX. All of a sudden, on location everything, started to go down hill to the point where we have to move them to another LAN which would allow DHCP support.

Then out of nowhere two of the telephones decided they want to be on static IP addresses after rebooting. After we put DHCP on them, Now those two fail to provision despite all the proper provisioning information on them. Then on one of the phones, the “Auto provision” page will only display half the page out of the blue. So we cannot even update the provisioning information on it because the “SaveSet” button is not there.

So , after six hours on work on these things and we only have ONE fully functioning telephone out of only four telephones, you can see where the attitude is coming from.

Will submit a ticket to see what they have to say. Thank you.


(Jared Busch) #10

Actually, yes.

Router, DHCP Server, Hypervisor, AD server if Windows network. That’s all that get static IP addresses.

Beyond that, member servers and printers get DHCP reservations. Other infrastructure if desired.


(Jared Busch) #11

All it takes is a logical conversation with people and you would be amazed at how easy silly requirements change.


#12

Bizarre thinking to me, your Asterisk server will be wandering around inside your network ?
How hard would it be to ssh tunnel into a web server on any phone inside?
How would you set up cups?
Do you have a mail server?

But if it works for you then fine.
It doesn’t for me and to me is not logical.

JM2CWAE


#13

There is no conversation when they have a set of standards they follow.


(Jared Busch) #14

How does using dhcp reservations for member servers and other infrastructure equate to your PBX wandering around?


(Reinhard) #15

freePBX 14.0.5.25
Sangoma 3.0.4.57

I think there are several bugs in the endpoint manager module, regarding the Sangoma phone template. And it seems they didnt get fixed yet, because nobody ever used those settings.

Look e.g. at the top of this thread. A user wants to set a fixed IP address on his Sangoma phone, which doesn’t work, and he gets the answer “use DHCP”…thats usually not a good sign :wink:

I filed two bug reports already. It is not possible to set LDAP protocol version3 using the webgui of the s705 endpointmanager…and it is not possible to set Sunday in the daylight saving settings, which is actually the day when daylight saving starts and ends in Europe… :wink:


(Tom Ray) #16

I just want to point out that everyone who switches to DST, no matter what part of the world, does it on Sunday. Because that is the technical start of the week. So are you sure you’re looking at that right? Because if you can’t set Sunday then that’s a bigger problem for more than just EU users.


(Reinhard) #17

Well, maybe it is a new bug. I use the freePBX version I mentioned above and the newest Sangoma firmware.
When I select Sunday in the Sangoma settings of the Endpoint manager (section Regional) and press the save and rebuild config button…exit the webgui regional settings and re-enter again…it says ‘Monday’. Tried it with several other weekdays, which worked…Sunday didnt…
Yet, I don’t know if this is just a problem of the freePBX webgui displaying it wrongly…or the setting really IS Monday…


(Tom Ray) #18

And what TIME did you set it to?


(Reinhard) #19

Last week in March and last week in October…


(Reinhard) #20

2:00am