send_test_email not working

I’m in the early stages of configuring my first FreePBX (RasPBX) box.

Thought I configured exim4 correctly. But the email is not arriving.

Took a look at /var/log/exim4/mainlog, all seems well:

2015-03-31 13:01:10 1Yd1PS-000657-Sl <= [email protected] U=root P=local S=415

2015-03-31 13:01:12 1Yd1PS-000657-Sl => [email protected] R=dnslookup T=remote_smtp H=gmail-smtp-in.l.google.com [74.125.70.26] X=TLS1.2:ECDHE_RSA_AES_128_GCM_SHA256:128 DN=“C=US,ST=California,L=Mountain View,O=Google Inc,CN=mx.google.com” C=“250 2.0.0 OK 1427828472 e37si6743584ioi.8 - gsmtp”

2015-03-31 13:01:12 1Yd1PS-000657-Sl Completed

It’s probably falling into an anti-spam trap somewhere.

When I ran dpkg-reconfigure exim4.config I chose the first option internet site; mail is sent and received directly using SMTP. The answers to the remaing questions seemed straight forward. I’ll redo that and capture all my answers shortly unless somebody points me in another direction.

Hmm. Maybe all I need to do is configure the firewall, etc. to allow incoming SMTP traffic.

Or, maybe I need to create some kind of magic email server certificate to authenticate my outgoing email.

I’m gonna guess that you’re probably failing the valid From address check. Just a guess though. When I set up mail servers, I usually disallow messages from “[email protected]” everywhere. The fact that your machine thinks the mail was delivered tells me that your local config is probably reasonable OK.