Sangoma S505 Caller ID shows phone extension instead of Caller number

Have a user with a Sangoma S505 phone and they report that when callls come in to that phone it shows 211 on the caller id, which is the extension of that phone. The other phones there are fine as far as I know. The problem is, they can’t go through call history to call someone back since it shows the extension. Not sure if this is a Sangoma or freepbx setting, have a bunch of Sangoma phones and never saw this. This is on Freepbx 14.0.17. Phone firmware is the latest 1.69 Where do I find the setting to make it show the correct caller id?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.