Sangoma phone Parking Hint DSS light not working?

I just did my 1st install using the Sangoma S500 phones.
I didn’t have a lot of time to play with the phones before we needed to install them and I have some question for you guys with lots of stick time on them.

I have park buttons on the phone DSS with value = 71 -75
When the main phone answers the call and parks it on 71 the DSS turns red on that phone only. I was expecting the DSS button 71 to light up red on all the phones.

Does anyone have a Sangoma phone to test this?

It would light red on all phones. It’s a BLF and controlled by the server not the phone.

FYI they are not DSS. That is old key system lanugage. When using them as a light please refer to the as BLF keys so people know you set them up as a BLF key and not something else like Speed Dial or phone app or it makes us wonder what you setup and start assuming things. Thanks.

So if this is my set up, then BLF keys should be RED when in use?

So I look in the subscribtions. I see only 4 out of the 14 phone watching 71
[email protected] : park:[email protected] State:Idle Presence:not_set Watchers 14
[email protected] : park:[email protected] State:Idle Presence:not_set Watchers 14
[email protected] : park:[email protected]& State:Idle Presence:not_set Watchers 0
[email protected] : park:[email protected] State:Idle Presence:not_set Watchers 4
[email protected] : park:[email protected] State:Idle Presence:not_set Watchers 14
[email protected] : park:[email protected] State:Idle Presence:not_set Watchers 14

So now I need to find out why only 4 are watching [email protected]

Ya that seems odd. I would reload asterisk with fwconsole r and see if that resolves it.

No, that didn’t fix it, it only added 1 more watcher.
If I can’t fix it today I’m going to reboot

A reboot wont change it.

Try rebooting your phones. This is a age old issue with Asterisk that when you restart asterisk it looses all hints and watchers until a phone resubsribes but a reload should fix it usually.

Will the reboot from the EPM work on Sangoma phone or just update the config

No it wont reboot the phone. It just pushes the update to the phones.

Is that why Aastra phone are programmed to reboot a 5am every day?

Never heard of such a thing about Aastra. That would seem weird to have it reboot at some set time like that.

Rebooting at 5AM every day might be a thing. It would explain some weird things I’ve seen with the one Aastra phone I’ve worked with.

EPM defaults to a re-sync time of 86400 seconds (24 hrs) and if the re-sync causes the phones to reboot, that might explain what you are seeing. I don’t know why they would all do it at the same time per day tho.

So in the logs on the PBX we should see a notify message being sent out.

I’m in my office most days before 5am and I can set my watch phone resettings. No other make of phones do this to me.

So I check a few PBX that are running this phone. They are resetting around 5am. I started at 5:11am and looked back. All my Aastra/Mitel phones reboot. I don’t see notify command being sent out.
What should I look for the log file when you issues the command notify-aastra-check extension_number

As a side note my Panasonic UT670 will reboot on that aastra-check command.

I called Mitel about this and I got laughter. I know what I know, the phone reboots around 5am

@posi211 maybe it’s caused by network issues, there have been reports of Aastra phones rebooting on dhcp lease changes (http://poorlydocumented.com/2013/01/aastra-phones-rebooting-after-dhcp-lease-changes/)

No, it’s a default setting in the phone
I when to go recreate it and found.

getting back to the original issue,
Rebooting the phones was the solution.

Do we have this Auto-Resync on the Sangoma’s?

Didn’t @lgaetz or @tonyclewis say something about the phone resyncing every 24 hours? I don’t think there’s a set time - I think they just reload their config once the old one is considered “expired”.

If the phone get unsubscribed from hints, maybe a reboot at 5am is a good idea