Sangoma P-series provisioning Endpoint Manager

Hi Guys ,

Using Sangoma P series phone m, P320 I am trying to provisioning them from the Endpoint Manager , but I got failed while enable DPMA .I ve been notified

don’t need to purchase Endpoint Manger Module if using Sangoma P series phones

– So I guess DPMA Is not necessary to enable then I left it and continue with the other feature on Endpoint Manger setting . When my new phone boots up , choosing Sangoma Configuration Server, the phone never get configured (Timed out contacting proxy …) . Do you think this is due of the error I received from the DPMA or it is about the Endpoint Manager license that I miss . Please let me know .
Looking forward to your reply .

Thanks !

You don’t need an Endpoint Manager license to manage Sangoma phones through it but pretty sure you do need DPMA Management module (this is a separate thing from the Endpoint Manager module) installed and enabled and configured for auto provisioning of the P series phones to work.

Yes, you have to enable DPMA in EPM. DPMA is the Digium phone module in Asterisk and the P-series phones are based on Digium phones.

Thank you , I understand i do need to enable this feature so i can user P series phone , but i am getting error 757 everytime i tried to install it , can you please tell how i can fix this .

error receiving

{“error”:{“type”:“Whoops\Exception\ErrorException”,“message”:“Undefined offset: 1”,“file”:“/var/www/html/admin/modules/endpoint/DpmaModel.class.php”,“line”:757}}

What version of freePBX & Asterisk? Did you update your system before you enabled DPMA?

Here someone describes a similar error.

Here is the asterisk version ,
Asterisk 16.24.1 built by mockbuild @ jenkins7 on a x86_64 running Linux on 2022-03-09 15:56:59 UTC
FreePBX 15.0.37

And i just perform an update but the issue remain .


As explained in the thread @Charles_Darwin linked to, have you tried manually installing the asterisk16-res_digium_phone.x86_64 package?

yum install asterisk16-res_digium_phone.x86_64

It fixed the problem for me.

1 Like

Many Thanks !

This single line of cmd fix the issue !!!

Many Thanks !

yum install asterisk16-res_digium_phone.x86_64

This single line of cmd fix the issue !!!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.