Unable to enable DPMA in Endpoint Manager Global Settings

Hi,
I am attempting to enable DPMA in the Global Settings of the Endpoint Manager.
Each time I try, I got the following error message:

{"error":{"type":"Whoops\\Exception\\ErrorException","message":"Undefined offset: 1","file":"\/var\/www\/html\/admin\/modules\/endpoint\/DpmaModel.class.php","line":741}}

dpma

FreePBX modules and packages are up to date.

What’s wrong?

Thanks.

From the command line, try running

fwconsole chown

and attempting to enable again. What version of EPM are you using?

same result. I get the error message.

EPM version: 16.0.69.4

There’s a slightly newer version, try installing

fwconsole ma downloadinstall endpoint --tag 16.0.69.7

If it still won’t work, and your system updates are current, then I recommend a support ticket.

fwconsole ma downloadinstall endpoint --tag 16.0.69.7
fwconsole chown
fwconsole restart

After that, always the same error message. :frowning_with_open_mouth:

I gonna try on a fresh install. Then I’ll open a support ticket if it doesn’t work either.

Thanks for your help and advices.

Just peeked at the source, that part is related to determining asterisk version. What ver of asterisk is running? If you’re not on 16 or 18, I recommend changing to one of those

https://wiki.freepbx.org/display/PPS/Changing+Major+Asterisk+Versions+on+the+Fly

I tried with Asterisk 16 and 18. Same result.

The root cause is when we enable DPMA it should automatically install the package package asterisk18-res_digium_phone.x86_64 (or package asterisk16-res_digium_phone.x86_64 depending on the asterisk version).

In my case, I don’t why, but it doesn’t work.

Solution: installing the package manually, then I can enable DPMA.

Thanks to Sangoma support for its help in diagnosis