Sangoma Desktop Phone Error

I’ve seen this error crop up on the forums, but so far none of the proposed fixes have worked for me. Curious if anyone has any idea what the actual underlying issue is, and if there are any other tricks to resolve it.

Opened a ticket with Sangoma, then sat on hold for 30 minutes only to be sent to voicemail to create a new/additional ticket.

You seem to have forgotten the error

It’s in the title, same exact error as in this post…

Interestingly enough, if I go into debug mode, and muck with the HTML enough so that I can get into the settings of the softphone, I can then quit the app and it works upon relaunch. This was obviously the result of falling back asswards into a workaround, so why this is occurring and how this managed to fix it is still a mystery.

Out of curiosity has anyone actually received support from Sangoma for commercial modules recently? It’s pretty clear that no-one is monitoring the FreePBX queue in their phone system. Their announcement in the queue frequently offers to “press *1 for a callback”, and when you do so, you get an access denied message. So far, crickets on the ticket I created. The call to my account manager goes to voicemail. Looks like I’m on my own.


For those following along, after 9 hours, I got a response saying I needed to buy support credits. Admittedly it’s been a long time since I have needed support for a commercial module, so upon reading the current T&C for commercial modules, I see that the purchase strictly gives you the ability to use the product (bugs and all), and installation/licensing support. In years past I was able to get some semblance of support for commercial modules, namely Zulu, without any additional purchases, so I was misguided in my assumption that Sangoma would keep up this practice.

I’ll spare my rant on paying for support for what is very clearly a bug, vs paying for support for my lack of knowledge or inability to understand a complicated product, the latter of which I am very willing to do. However, I wanted the community to be aware of what to expect when they run into bugs in commercial modules.

1 Like

@thx2000 How did this resolve? We are getting the same error.

Sounds like he didn’t. It is a bug but Sangoma told him to pay or get bent. So basically someone with support credits needs to pay for the bug fix

I basically had the same response when I was trying to get support. Shoutout to Matt S for the assist!

Ran into this after a recent update from Asterisk 16 to 18. The issue is caused by your Users (User Management) not having a Group set. I had an “All Users” Group that I linked which fixed the problem.

1 Like

I updated this post with my fix. It wasn’t just that the user’s needed to be added to a group. The Contact Manager details for the group had to be configured as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.