Sangoma Connect - Mobile Client


(Tony B) #61

Hi All,
I have configure my firewall to allow inbound from any to pbx server pjsip port for sangoma connect,
I have enable PBX firewall and i have enable Responsive Firewall for pjsip

Sangoma Connect works my question is that PJSIP port has to be open to the world or is there something im missing.

Thank you All


(Tony Freestone) #62

Some background -
We have been using FreePBX v13 for about 6 years as our enterprise PBX as well as our contact center platform (Noble Systems) audio path. We have about 150 concurrent reps all working from home, currently using the UCP/WebRTC phone via a Chromebox. Each rep connects back to the corporate network via a locally installed Cisco AnyConnect client so the PBX is on-net, so to speak.

We are working to migrate to v15 over the next 15-30 days. Our testing of the v15 UCP/WebRTC phone exposed a bug in the PJSIP device which makes it not usable for production. The bug is that every 600 seconds after initial login, the WebRTC phone refreshes its buttons UI back to just the “Call” button, no matter if a call is in progress or not.

So in turn we have started to test out the Sangoma Connect option. The first test was using a fresh distro install, and that worked without an issue. The next step was to test it on our POC v15 VM that was restored from a v13 backup.

The v15 restored system is working with the Sangoma Connect extension running on the Chromebox, but the Cloud Connect Agent Status is stating something other than just “Running” as the fresh distro did.

The v13-v15 restore VM is showing the CloudConnect Agent Status as “Running (disconnected from server)”

image

We were able to get the Sangoma Connect Android app to register the extension and it can make and accept calls.

The connect-proxy.log entry looks fine as well (below).

Is the status in the Sangoma Connect module/tab just a UI bug?

===================================================
72 {“name”:“socket-io-router”,“hostname”:"[our FQDN hostname]",“pid”:6204,“level”:30,“msg”:“SocketIOClient Connecting to remote wss://proxy.iot.sangoma.tech:443 with sid e1a08742-38a7-42e7-a726-0e5747abc7fc and token CFmO8Vjsvy”,“time”:“2021-03-08T18:49:19.263Z”,“v”:0}
73 {“name”:“socket-io-router”,“hostname”:"[our FQDN hostname",“pid”:6204,“level”:30,“msg”:“SocketIOClient [mN5F8oztcBufNjZbAFYQ] Connected”,“time”:“2021-03-08T18:49:19.609Z”,“v”:0}