Sangoma Connect - Mobile Client


(Lorne Gaetz) #1

Sangoma Connect beta is open.

You may have been hearing about this over the last few months while we’ve been testing internally and with invited customers. If you haven’t heard, Sangoma Connect is the next generation mobile client offering from Sangoma for FreePBX and PBXact. Anyone with a Zulu user license (including the free 2 user trial) is able to try it out. If you want to be part of the beta testing phase, you can follow the installation and setup instructions here:

https://wiki.freepbx.org/display/CONNECT/Testing+Sangoma+Connect+for+Mobile

Sangoma Connect does require that you have a user management user with a pjsip primary extension. The App will register to the PJSIP TCP transport, so you may need to enable that in Asterisk SiP Settrings and restart Asterisk. See the full technical details here:
https://wiki.freepbx.org/display/CONNECT/Technical+Details+and+Limitations


Zulu uses IP not hostname
(Charles Darwin) #2

Is port-forwarding from my freePBX server to my router still required, like it is with Zulu?


(Lorne Gaetz) #3

Only for the SIP (PJSIP/TCP) signaling. The connection from the PBX to the Sangoma Connect cloud servers is outbound only.

edit - And the RTP range (default 10k-20k) as well.


(Charles Darwin) #4

In the user management (SangomaConnect Tab) it says my EPM module is too old. I have 15.0.27.4
I just use one phone with the EPM for testing, which is a Sangoma s705. When I try to update (edge) the EPM module it says it is the same as online version…yet in the instructions it says I need 15.0.27.38 or newer? How to get there?


(Lorne Gaetz) #5

Edge version of EPM now is 15.0.27.43 which you can install with:

fwconsole ma downloadinstall endpoint --tag 15.0.27.43

(Charles Darwin) #6

There seems to be a problem with the repositories
It says
Unable to update module endpoint - 15.0.27.43, it does not exist:


(Lorne Gaetz) #7

That command works for me. Pls open a support ticket so we can figure out what’s going on:
https://wiki.freepbx.org/display/FPAS/How+To+Open+A+Support+Ticket


#8

So this inserts a third-party system ("Sangoma Connect cloud) into an on-prem setup? If so, is this required to for it to work, or can it function as the current Zulu client does; with only direct connections to the end points?


(Lorne Gaetz) #9

There is a cloud server that proxies encrypted data between the client and the PBX. It is required, and is used for the initial provisioning setup as well as for non-voice services such as contact management.


#10

That’s unfortunate. It adds a failure point and potential security hole to the previous configuration.


(Jared Busch) #11

The point is a mobile client that always works. you are never going to get that with an only on prem solution.


(Charles Darwin) #12

Somehow I had to do this
fwconsole setting MODULE_REPO http://mirror1.freepbx.org,http://mirror2.freepbx.org

my original setting was http://mirror.freepbx.org…which did not find any updates…freePBX 15.0.16.75

anyway…I can now proceed with beta testing…


(Lorne Gaetz) #13

my working setting:

[root@uc-51459655 ~]# fwconsole setting MODULE_REPO
Setting of "MODULE_REPO" is (text)[https://mirror.freepbx.org]

#14

I’m not sure how adding a failure point lands a system at more always working. If an on-prem solution is correctly configured, it will always work, barring new bad code, ISP failure, or the like, which would affect the new system as well.

Adding complication rarely, in my experience, reduces failures.


(Jared Busch) #15

You obviously have no idea how iOS or Android work then.


#16

Thanks for the cogent response.


(Charles Darwin) #17

Thanks, I switched it back to your setting. In the module admin it shows me this…but I dont care :wink:

I just read in another thread that some of the rpms are missing on your servers…so I thought it might be related to this problem. The fwconsole setting change to the two mirror servers was the only way to download the newest EPM…I have no idea why…

…and now for someting completely different…beta testing :wink:


(Lorne Gaetz) #18

Again, I have no issues with that repo. I suspect you have a caching issue, you can disable ‘module admin caching’ in advanced settings to test my theory.


(Charles Darwin) #19

nope…deactivating module-admin-caching wont make a difference…

anyway…I have a question regarding the SangomaConnect Client: Where can I set the port, which should be opened (router) for the SIP signaling? Can I choose a random port? Without the forwarding the client does not connect.


#20

Since @lgaetz mentioned it’s using PJSIP TCP, set the TCP listening port in Asterisk SIP Settings.