Sangoma A200 Installation Procedure - Problem

Hi all,

I’ve installed a new A200 by following the linux install procedure and my trunks/lines are not showing up. I do get the following error when I run the config utility----Wanpipe1: No FXO/FXS modules are found — and I noticed that everywhere in the module files that Sangoma is commented out and no channels are appearing. Any suggestions on what to look for or add the channels will be appreciated.

Have you tried Sangoma support sine you are having a issue with thier hardware? I’m not trying duck your question but it is a basic setup issue with the card and asterisk that you are having a issue with not FreePBX.

Yes, I have contacted Sangoma and this was their response:

If you need to install our drivers, for our card to work with freePBX, you can find this information ( under Asterisk Linux Source Installation. To install FreePBX you will need to check for support.

I was hoping that someone else had successfully installed the A200 and was looking to see how their FreePBX config files showed the channels.

But, as an update we have come to the conclusion that the FXO board on the card is most likely bad and will have to be replaced.

you have to love it…

FYI: I don’t have or use Sangoma cards but have helped others from time to time.

That just shows how little Sangoma knows about FreePBX. FreePBX has nothing to do with the installation, setup or operation of the card.

Yes Sangoma cards require thier own dirvers to work, those drivers talk to asterisk not FreePBX. FreePBX talks to asterisk once it is installed and working correctly. It finds out about the available interfaces by quering asterisk and having it report what it see’s configured, so if they are not configured correctly it will not see them.

In asterisk you can see if the drivers are working (or not) by typing at the asterisk cli zap show channels
doing that should show the channels that are on the card that you have just like any other zap hardware device. If not the then the config for the card, drivers and or card are at fault.

I do know that there is a differance in the configs if you are using asterisk 1.2 versus 1.4 for T1/E1/PRI cards which they do not clearly document. Not sure if there are any querks like that for the analog cards or the A200. Which version of asterisk are you running?

Sangoma also has some diagnostic tools that should have come with the drivers, have you looked into them.

On the digium zaptel side you could do a ztcfg -vv that would show you what the zaptel drivers see and have configured and once you have that working they should be viewable in asterisk and thus seen in FreePBX. I don’t know what the wanpipe driver equivalent commands are but I do know that they exist.

Good Luck.